Bug 1021626 - Unable to find custom task from service repository in Shape Repository
Unable to find custom task from service repository in Shape Repository
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER5
: 6.0.0
Assigned To: Tihomir Surdilovic
Sona Mala
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 12:31 EDT by Sona Mala
Modified: 2014-08-06 16:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Summary: Importing a custom task from the service repository is successful but this task is not available in the Shape Repository. The git repository contains the custom task but it is not displayed by the Designer and the WID editor for use when creating a new Process. Cause: Consequence: Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:10:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Video file - step to reproduce (6.71 MB, video/webm)
2013-10-21 12:31 EDT, Sona Mala
no flags Details
Service repository with Jabber Task (2.87 KB, application/zip)
2013-10-21 12:31 EDT, Sona Mala
no flags Details

  None (edit)
Description Sona Mala 2013-10-21 12:31:08 EDT
Created attachment 814700 [details]
Video file - step to reproduce

Description of problem:
Import of custom task from the service repository is successful but I am not able to find such task in Shape Repository.

Custom task is successfully installed into git repository but is not displayed by Designer and WID editor.


Version-Release number of selected component (if applicable):
6.0.0 ER4 BPMS

Steps to Reproduce (see attached video:
1. create process
2. connect to service repository from file system (service repository is attached)
3. import "Jabber" service
4. reopen process
5. look for "Communication" section
6. find Jabber.wid in "global" directory
7. clone myRepo.git and look directly into repository

Actual results:
step 3: alert "Assets successfully installed."
step 5: there is no "Communication" section
step 6: WID editor is empty
step 7: Git repository contains a commit with message "Created asset Jabber.wid
" and file is presented in repository (non-empty)


Expected results:
step 3: alert "Assets successfully installed."
step 5: there is "Communication" section and it contains "Jabber" task
step 6: WID editor is not empty
step 7: Git repository contains a commit with message "Created asset Jabber.wid
" and file is presented in repository (non-empty)


Additional info:
Server.log does not contains any error.
Comment 1 Sona Mala 2013-10-21 12:31:53 EDT
Created attachment 814701 [details]
Service repository with Jabber Task
Comment 3 Tihomir Surdilovic 2013-10-21 22:25:48 EDT
fix in designer master and 6.0.x branches
Comment 4 Sona Mala 2013-12-12 04:58:25 EST
Verified for ER5.


Note: there is still problem that WID editor for imported Custom task is still empty and git repository contains non-empty file. I have reported a new bugzilla issue for this problem https://bugzilla.redhat.com/show_bug.cgi?id=1040910

Note You need to log in before you can comment on or make changes to this bug.