Bug 1021752 - Product view: "Remove Product" button greyed out without context
Product view: "Remove Product" button greyed out without context
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Walden Raines
Tazim Kolhar
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 22:14 EDT by Corey Welton
Modified: 2016-04-25 20:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 10:06:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2013-10-21 22:14:54 EDT
Description of problem:
Sometimes the "Remove Product" button is grayed out and (basically) unclickable -- presumably because the content therein has been promoted, etc., -- but really there's no context to why this has been grayed out.

Version-Release number of selected component (if applicable):
Satellite-6.0.2-RHEL-6-20131017.1

How reproducible:


Steps to Reproduce:
1.  Create a product w/ content (i.e., Google Chrome) and promote it out of Library
2.  Navigate to Content > Repositories > Product > $product
3.  Noting it's grayed out, click the "Remove Product" button on the page; hover over it, etc.  

Actual results:

No context; new users might wonder why they can't click it.

Expected results:
A tooltip or something explaining that it would have to be demoted/removed from environments before it can be removed, etc.

Additional info:
Comment 2 Walden Raines 2013-10-23 15:44:43 EDT
PR:  https://github.com/Katello/katello/pull/3263
Comment 3 Walden Raines 2013-10-24 16:02:04 EDT
commit 21637654d8886752afbb961a5912c946ac4bf89a
Merge: 7201ea3 4af4ba2
Author: Walden Raines <walden@redhat.com>
Date:   Thu Oct 24 13:00:48 2013 -0700

    Merge pull request #3263 from waldenraines/bug-1021752
    
    Bug #1021752 - adding a tool tip to disabled product deletion button.

commit 4af4ba25e8f2e27b0ca14a7024b0406386e16595
Author: Walden Raines <walden@redhat.com>
Date:   Wed Oct 23 15:37:42 2013 -0400

    Bug #1021752 - adding a tool tip to disabled product deletion button.
Comment 5 Tazim Kolhar 2014-04-28 03:18:00 EDT
VERIFIED:
remove Product button highlighted
Comment 6 Bryan Kearney 2014-07-02 10:06:43 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.

Note You need to log in before you can comment on or make changes to this bug.