Bug 102177 - error while loading shared libraries: /usr/lib/libpthread.so.0: invalid ELF header
error while loading shared libraries: /usr/lib/libpthread.so.0: invalid ELF h...
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-12 05:46 EDT by Sebastien
Modified: 2016-11-24 09:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-18 13:00:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastien 2003-08-12 05:46:52 EDT
Description of problem:
Since I upgraded glibc-2.2.5-43 to glibc-2.3.2-68, each time I want to launch a 
KDE application like kview I get this error message:

kview: error while loading shared libraries: /usr/lib/libpthread.so.0: invalid 
ELF header

Any solutions?

Thanks in advance

S.
Comment 1 Jakub Jelinek 2003-08-12 10:00:20 EDT
/usr/lib/libpthread.so.0 ? glibc rpm certainly does not provide a file nor
link like that (only /lib/tls/libpthread.so.0, /lib/i686/libpthread.so.0 and
/lib/libpthread.so.0).
Comment 2 Sebastien 2003-08-12 10:05:33 EDT
I fixed the problem. The link was not correct. I do not know if it is because 
the installation of the new package, but I had not this issue before installing 
it.
Comment 3 Ulrich Drepper 2003-08-18 13:00:46 EDT
It's a user bug of some sort.  Stray symlinks cause all kinds of problems.  If
you found out who created the symlink let us know.

Note You need to log in before you can comment on or make changes to this bug.