Bug 1021773 - [RHSC] Import host dialog hangs
[RHSC] Import host dialog hangs
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: RHGS 2.1.2
Assigned To: Shubhendu Tripathi
Shruti Sampat
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 00:46 EDT by Shruti Sampat
Modified: 2015-05-13 12:30 EDT (History)
9 users (show)

See Also:
Fixed In Version: cb10
Doc Type: Bug Fix
Doc Text:
Previously, if import host was triggered for other peers of an already added host, that host name was getting listed in the Import Hosts window and the import hosts operation used to hang. Now, with this update, the Import Hosts is successful.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:42:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine logs (273.53 KB, text/x-log)
2013-10-22 00:46 EDT, Shruti Sampat
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20697 None None None Never
oVirt gerrit 21535 None None None Never
Red Hat Product Errata RHEA-2014:0208 normal SHIPPED_LIVE Red Hat Storage 2.1 enhancement and bug fix update #2 2014-02-25 07:20:30 EST

  None (edit)
Description Shruti Sampat 2013-10-22 00:46:08 EDT
Created attachment 814849 [details]
engine logs

Description of problem:
-----------------------
After adding a host using gluster peer probe, to a cluster managed by RHSC, when trying to import the newly added host to the engine, the import host dialog hangs. The following is seen in the engine logs - 

2013-10-22 03:15:02,468 ERROR [org.ovirt.engine.core.bll.GetServerSSHKeyFingerprintQuery] (ajp-/127.0.0.1:8702-4) Could not fetch fingerprint of host 192.168.122.1 with message: RuntimeSshException: Failed to get the session.

The hosts in the cluster have the bridge 'virbr0' on them.


Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.2-0.0.scratch.beta1.el6_4 

How reproducible:
Frequently.

Steps to Reproduce:
1. Create a cluster and add some hosts. On one of the hosts run the gluster peer probe command to add one more host to the cluster.
2. In the UI, click on the Clusters tab and select the cluster.
3. Click on the Import link in the General tab for the cluster.

Actual results:
Import host dialog hangs.

Expected results:
Import host should succeed.

Additional info:
Comment 2 Matt Mahoney 2013-12-03 09:11:19 EST
Verified in cb10.
Comment 3 Shalaka 2014-01-08 01:38:54 EST
Please review the edited DocText and signoff.
Comment 4 Shubhendu Tripathi 2014-01-08 03:33:16 EST
Doc text looks fine
Comment 5 Shalaka 2014-01-21 06:48:42 EST
Edited the text as suggested. Please review and signoff.
Comment 6 Shubhendu Tripathi 2014-01-21 06:51:37 EST
looks fine
Comment 8 errata-xmlrpc 2014-02-25 02:42:24 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.