Bug 102178 - Missing texinfo and ghostscript build deps
Summary: Missing texinfo and ghostscript build deps
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: nasm (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Richard Henderson
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-12 10:22 UTC by Matthias Saou
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-21 16:20:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthias Saou 2003-08-12 10:22:13 UTC
While trying to rebuild the latest nasm package from Servern on an older Red Hat
Linux release, I noticed that some build requirements were missing from the spec
file.

BuildRequires: texinfo, ghostscript

This should probably be added, since when trying to rebuild on a minimal build
system, I got the following error :

[...]
Producing Documentation Intermediate Paragraphs: done.
mv -f *.html html
: Generated by side effect
mkdir -p info
makeinfo nasmdoc.texi
make[1]: makeinfo: Command not found
make[1]: *** [info/nasm.info] Error 127

Then this one :

[...]
Producing Documentation Intermediate Paragraphs: done.
mv -f *.html html
: Generated by side effect
mkdir -p info
makeinfo nasmdoc.texi
mv -f *.info *.info-* info
perl ./genpsdriver.pl > nasmdoc.ps
ps2pdf -dOptimize=true   nasmdoc.ps nasmdoc.pdf
make[1]: ps2pdf: Command not found
make[1]: *** [nasmdoc.pdf] Error 127

After adding both build dependencies, the package and its docs rebuilt fine.
Would you consider adding them?

Matthias

Comment 1 Matthias Saou 2003-10-08 20:07:42 UTC
Seems like nasm-0.98.38-1 in current Rawhide (at the time of Fedora 0.94) still
lacks those dependencies. When rebuilt without, as the only explicit dependency
is perl, build fails, but adding just those two components to the BuildRequires
makes everything work fine.

Could this be fixed? If texinfo and ghostscript are or will be explicitely
mentionned as basic expected packages on any build system, then just close this
bug, but otherwise, it's just a matter of adding two words to get the proper fix :-)

Comment 2 Alan Cox 2004-06-21 16:20:46 UTC
Added to cvs



Note You need to log in before you can comment on or make changes to this bug.