Bug 1021800 - quota: Input/output error with cp command
quota: Input/output error with cp command
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Bug Updates Notification Mailing List
Saurabh
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 02:46 EDT by Saurabh
Modified: 2016-01-19 01:13 EST (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.40rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:43:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-10-22 02:46:59 EDT
Description of problem:
Here I had single brick distribute volume.
enabled quota and set a limit after that tried to create random size files in it.
Now again increased the quota limit to twice of earlier one set.
This time copy the files earlier created in a directory.

And it says EIO.



Version-Release number of selected component (if applicable):
glusterfs3.4.0.35.rhs

How reproducible:
happened twice till now

Steps to Reproduce:
1. create a volume, start it
2. enable quota, set limit on the root of the volume to 1GB
3. mount it over nfs
4. create a directory inside the mountpoint
5. start creating random sized files, till quota limit is reached
6. increase the limit to 2GB
7. create a new directory, cp the data created earlier to newly created directory

Actual results:

[root@konsoul dir3]# cp * ../dir4/
cp: closing `../dir4/f.96': Input/output error
cp: closing `../dir4/f.97': Input/output error
cp: closing `../dir4/f.98': Input/output error
cp: closing `../dir4/f.99': Input/output error

Also, the same files that are showing EIO, are copied as truncated files.

example,
[root@konsoul dir3]# ls -l f.96
-rw-r--r--. 1 root root 12582912 Oct 22  2013 f.96
[root@konsoul dir3]# ls -l ../dir4/f.96
-rw-r--r--. 1 root root 7405568 Oct 22  2013 ../dir4/f.96
[root@konsoul dir3]# pwd
/mnt/nfs-dist1/dir1/dir1/dir2/dir3
[root@konsoul dir3]# 


Expected results:
if space is available then it should mention "Disk quota exceeded" not EIO

Additional info:

Client is RHEL 6.2
Comment 2 Saurabh 2013-10-22 02:59:53 EDT
updating the Expected results section,
Expected results:
if space is NOT available then it should mention "Disk quota exceeded" not EIO
Comment 3 Gowrishankar Rajaiyan 2013-11-09 05:49:20 EST
Don't see this with glusterfs-server-3.4.0.40rhs-1.el6rhs.x86_64


[shanks@localhost Music]$ df -h .
Filesystem                Size  Used Avail Use% Mounted on
10.70.43.3:/shanks-quota  1.0G  1.0G     0 100% /home
[shanks@localhost Music]$


[shanks@localhost Music]$ cp ../Downloads/en_server_2012_x64.iso .
cp: writing `./en_server_2012_x64.iso': Disk quota exceeded
cp: closing `./en_server_2012_x64.iso': Disk quota exceeded
[shanks@localhost Music]$


[root@server1 ~]# gluster vol quota shanks-quota limit-usage /shanks/Music 2GB
volume quota : success
[root@server1 ~]# gluster vol quota shanks-quota list /shanks/Music
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/shanks/Music                              2.0GB       80%       1.0GB   1.0GB
[root@server1 ~]# 


[shanks@localhost Music]$ mkdir test1
[shanks@localhost Music]$ cp 1GBfile.1 test1/
[shanks@localhost Music]$ cp 1GBfile.1 test1/1GBfile.2
cp: writing `test1/1GBfile.2': Disk quota exceeded
cp: closing `test1/1GBfile.2': Disk quota exceeded
[shanks@localhost Music]$ 


Version: glusterfs-server-3.4.0.40rhs-1.el6rhs.x86_64
Comment 4 Saurabh 2013-11-11 05:10:37 EST
based on comment#3, moving it to verified
Comment 5 errata-xmlrpc 2013-11-27 10:43:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.