Bug 1021840 - qemu core dump during migration w/ file transfer
qemu core dump during migration w/ file transfer
Status: CLOSED DUPLICATE of bug 1006663
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Juan Quintela
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 04:08 EDT by CongLi
Modified: 2013-12-23 13:34 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-23 13:34:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CongLi 2013-10-22 04:08:58 EDT
Description of problem:
qemu core dump during migration w/ file transfer

Version-Release number of selected component (if applicable):
kernel-3.10.0-34.el7.x86_64
qemu-kvm-1.5.3-9.el7.x86_64

How reproducible:
1/5

Steps to Reproduce:
1. Boot a RHEL.7.0 guest
2. scp file from host to guest
3. Migrate guest to 'exec:nc localhost 5200' while file transfer

Actual results:
qemu core dump

Expected results:
Both migration & file transfer are successful

Additional info:
1. gdb:
(gdb) bt full
#0  0x00007f9c15231999 in raise () from /lib64/libc.so.6
No symbol table info available.
#1  0x00007f9c152330a8 in abort () from /lib64/libc.so.6
No symbol table info available.
#2  0x00007f9c1a12765c in runstate_set (new_state=new_state@entry=RUN_STATE_FINISH_MIGRATE) at vl.c:675
        __PRETTY_FUNCTION__ = "runstate_set"
#3  0x00007f9c1a12f107 in vm_stop_force_state (state=state@entry=RUN_STATE_FINISH_MIGRATE)
    at /usr/src/debug/qemu-1.5.3/cpus.c:1152
No locals.
#4  0x00007f9c1a0bcba5 in migration_thread (opaque=0x7f9c1a626c00 <current_migration.27031>) at migration.c:534
        current_time = <optimized out>
        pending_size = <optimized out>
        s = 0x7f9c1a626c00 <current_migration.27031>
        initial_time = 20747949
        initial_bytes = 7696292
        max_size = 566670
        start_time = 20748052
        old_vm_running = false
#5  0x00007f9c181acde3 in start_thread () from /lib64/libpthread.so.0
No symbol table info available.
#6  0x00007f9c152f21ad in clone () from /lib64/libc.so.6
No symbol table info available.
(gdb) q

2. qemu CML:
/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/virt/qemu/qemu \
    -S \
    -name 'virt-tests-vm1' \
    -nodefaults \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20131016-204539-yMzPDLTy,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control \
    -chardev socket,id=serial_id_serial1,path=/tmp/serial-serial1-20131016-204539-yMzPDLTy,server,nowait \
    -device isa-serial,chardev=serial_id_serial1 \
    -chardev socket,id=seabioslog_id_20131016-204539-yMzPDLTy,path=/tmp/seabios-20131016-204539-yMzPDLTy,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20131016-204539-yMzPDLTy,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=0x4 \
    -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/virt/shared/data/images/RHEL-Server-7.0-64-virtio.qcow2',index=0,if=none,id=drive-virtio-disk1,media=disk,cache=none,snapshot=off,format=qcow2,aio=native \
    -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk1,bootindex=0 \
    -device rtl8139,netdev=idVBA310,mac='9a:5d:5e:5f:60:61',bus=pci.0,addr=0x3,id='idu77rQG' \
    -netdev tap,id=idVBA310,fd=37 \
    -m 4096 \
    -smp 2,maxcpus=2,cores=1,threads=1,sockets=2 \
    -cpu 'Opteron_G3' \
    -M pc \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 \
    -vnc :0 \
    -vga cirrus \
    -rtc base=utc,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off   \
    -no-kvm-pit-reinjection \
    -enable-kvm \
    -incoming "exec:nc \
    -l 5200"

3. cpuinfo:
processor	: 3
vendor_id	: AuthenticAMD
cpu family	: 16
model		: 4
model name	: AMD Phenom(tm) II X4 B95 Processor
stepping	: 2
microcode	: 0x1000086
cpu MHz		: 800.000
cache size	: 512 KB
physical id	: 0
siblings	: 4
core id		: 3
cpu cores	: 4
apicid		: 3
initial apicid	: 3
fpu		: yes
fpu_exception	: yes
cpuid level	: 5
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nopl nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs skinit wdt hw_pstate npt lbrv svm_lock nrip_save
bogomips	: 5985.07
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 48 bits physical, 48 bits virtual
power management: ts ttp tm stc 100mhzsteps hwpstate
Comment 3 Hai Huang 2013-12-18 09:31:00 EST
*** Bug 1006663 has been marked as a duplicate of this bug. ***
Comment 4 Hai Huang 2013-12-23 13:34:06 EST

*** This bug has been marked as a duplicate of bug 1006663 ***

Note You need to log in before you can comment on or make changes to this bug.