This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1021904 - smbd process terminates with SIGABRT when a client attempts to mount glusterfs share when glusterfs is built with DEBUG flag
smbd process terminates with SIGABRT when a client attempts to mount glusterf...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: libgfapi (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krutika Dhananjay
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 06:09 EDT by Krutika Dhananjay
Modified: 2014-04-17 07:49 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 07:49:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2013-10-22 06:09:08 EDT
Description of problem:
smbd process terminates with SIGABRT, when a remote client attempts to mount glusterfs share. Note that this happens when glusterfs is built with -DDEBUG flag.

Version-Release number of selected component (if applicable):


How reproducible:
Often

Steps to Reproduce:
1. Create and start a volume.
2. Start smbd service
3. Mount the share from a remote client.

Mount fails.

Actual results:
On inspecting the samba logs and the core files location, it was found that smbd process had crashed with SIGABRT.

Expected results:
Mount must not fail, and smbd must not crash.

Additional info:
Comment 1 Anand Avati 2013-10-24 05:21:49 EDT
REVIEW: http://review.gluster.org/6134 (gfapi: fix mem-types initialisation) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Anand Avati 2013-10-24 16:56:19 EDT
COMMIT: http://review.gluster.org/6134 committed in master by Anand Avati (avati@redhat.com) 
------
commit 93c49c6e8c443426792b8e6cf24805516fdcc9bd
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Wed Oct 23 13:39:18 2013 +0000

    gfapi: fix mem-types initialisation
    
    ... and also fill the body of mem_acct_init().
    
    Change-Id: I457d0629c20f999dd2f50e710c75b1c7575b6c19
    BUG: 1021904
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/6134
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 3 Niels de Vos 2014-04-17 07:49:52 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.