Bug 1021917 - Fail to restore the snapshot of a JBossEWS-1.0 app to the existing one
Fail to restore the snapshot of a JBossEWS-1.0 app to the existing one
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Paul Morie
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 06:24 EDT by Zhe Wang
Modified: 2015-05-14 19:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 22:26:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhe Wang 2013-10-22 06:24:46 EDT
Description of problem:
Given a JBossEWS-1.0 app, it fails to restore its snapshot to an existing app.

Version-Release number of selected component (if applicable):
devenv_3927

How reproducible:
always

Steps to Reproduce:
1. create a JBossEWS-1.0 app
2. create a new page under src/main/webapp/ dir with the following code:

<--------testpage.jsp-------->

 <html>
   <head><title>WebPage factory</title></head>
   <body>
     <% out.println("version #num#"); %>
   </body>
 </html>


<---------------------------->

3. change the #num# string to "1"

4. push the change

5. check the testpage.jsp page to see if the change takes effect (print "version 1")

6. save a snapshot of this app

7. change the output string to "version 2"

8, push the change

9. check if the output string becomes "version 2" in testpage.jsp

10. restore this app with the tarball saved in Step 6

11. check the testpage to see if it prints "version 1".

Actual results:
In Step 5 and 9, the page was changed as expected. However, although the CLI showed the restoration was successful,  it actually failed to restore the testpage.jsp (of "version 1") in Step 11.

Expected results:
It should be successful to restore the snapshot of a JBossEWS-1.0 app to the existing one.

Additional info:
Comment 1 Paul Morie 2013-10-28 12:10:05 EDT
PR submitted
Comment 2 openshift-github-bot 2013-10-28 19:59:35 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/ddfdc079af35838b20df8d02000ef66215198510
Fix bug 1021917: update snapshot/restore for new build/deployment
Comment 3 Zhe Wang 2013-10-30 04:19:31 EDT
The bug is still reproducible in INT(devenv_3965).
Comment 4 Zhe Wang 2013-10-30 05:42:43 EDT
I was also able to reproduce this bug in devenv_3967.
Comment 5 Paul Morie 2013-10-30 11:29:30 EDT
Works for me in devenv_3968
Comment 6 Zhe Wang 2013-10-31 01:25:07 EDT
Verified this bug in INT(devenv_3971)

Note You need to log in before you can comment on or make changes to this bug.