Bug 1021933 - attaching subscription to ak does not disable it allowing multiple addition
attaching subscription to ak does not disable it allowing multiple addition
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Sachin Ghai
: Regression, Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 07:02 EDT by Garik Khachikyan
Modified: 2015-01-04 17:00 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 10:14:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
5 subscriptions of the same prod. (66.36 KB, image/png)
2013-10-22 07:02 EDT, Garik Khachikyan
no flags Details
Remove tab shows both "Red Hat Employee Subscriptions" (31.38 KB, image/png)
2014-06-02 02:53 EDT, Sachin Ghai
no flags Details
since both empolyee subscriptions are already added, so "Add" tab doesn't show any of them (37.97 KB, image/png)
2014-06-02 02:54 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Garik Khachikyan 2013-10-22 07:02:09 EDT
Created attachment 814935 [details]
5 subscriptions of the same prod.

Description of problem:
Dangerous issue appears recently (as regression) allowing to add a subscription multiple times to an activation key. as a result (consequence I believe) RHSM shows still the subscription to be available right after having the system registered to Sat6 via the activation key.

Version-Release number of selected component (if applicable):
the latest drop:
---
candlepin-0.8.25-1.el6sam.noarch
candlepin-cert-consumer-dionysus.usersys.redhat.com-1.0-1.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.25-1.el6sam.noarch
candlepin-tomcat6-0.8.25-1.el6sam.noarch
createrepo-0.9.9-21.2.pulp.el6sat.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-1.4.6-44.el6sat.noarch
katello-agent-1.4.4-3.el6sat.noarch
katello-all-1.4.6-44.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-cli-1.4.3-26.el6sat.noarch
katello-cli-common-1.4.3-26.el6sat.noarch
katello-common-1.4.6-44.el6sat.noarch
katello-configure-1.4.7-7.el6sat.noarch
katello-configure-foreman-1.4.7-7.el6sat.noarch
katello-foreman-all-1.4.6-44.el6sat.noarch
katello-glue-candlepin-1.4.6-44.el6sat.noarch
katello-glue-elasticsearch-1.4.6-44.el6sat.noarch
katello-glue-pulp-1.4.6-44.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-selinux-1.4.4-4.el6sat.noarch
m2crypto-0.21.1.pulp-8.el6sat.x86_64
mod_wsgi-3.4-1.pulp.el6sat.x86_64
pulp-katello-plugins-0.2-1.el6sat.noarch
pulp-nodes-common-2.3.0-0.22.beta.el6sat.noarch
pulp-nodes-parent-2.3.0-0.22.beta.el6sat.noarch
pulp-puppet-plugins-2.3.0-0.22.beta.el6sat.noarch
pulp-rpm-handlers-2.3.0-0.22.beta.el6sat.noarch
pulp-rpm-plugins-2.3.0-0.22.beta.el6sat.noarch
pulp-selinux-2.3.0-0.22.beta.el6sat.noarch
pulp-server-2.3.0-0.22.beta.el6sat.noarch
python-isodate-0.5.0-1.pulp.el6sat.noarch
python-oauth2-1.5.170-3.pulp.el6sat.noarch
python-pulp-agent-lib-2.3.0-0.22.beta.el6sat.noarch
python-pulp-bindings-2.3.0-0.22.beta.el6sat.noarch
python-pulp-common-2.3.0-0.22.beta.el6sat.noarch
python-pulp-puppet-common-2.3.0-0.22.beta.el6sat.noarch
python-pulp-rpm-common-2.3.0-0.22.beta.el6sat.noarch
python-qpid-0.18-5.el6_4.noarch
qpid-cpp-client-0.14-22.el6_3.x86_64
qpid-cpp-client-ssl-0.14-22.el6_3.x86_64
qpid-cpp-server-0.14-22.el6_3.x86_64
qpid-cpp-server-ssl-0.14-22.el6_3.x86_64
ruby193-rubygem-foreman-katello-engine-0.0.17-6.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.12-3.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
signo-katello-0.0.23-2.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1.import RH manifest, enable "Red Hat Enterprise Linux 6 Server (RPMs)" and "Red Hat Subscription Asset Manager (for RHEL 6 Server) (RPMs)" all repos.
2.promote the whole product to the environment
3.create an activation key for that env.
4. in the tab of "Available Subscriptions" do check the "Red Hat Enterprise Linux Server, Standard (1-2 sockets) (Up to 4 guests)" and attach it to the key.
5. NOTE that right after that the subscription *still* remains as available (THIS IS the issue) allowing to attach it again and again. 

Actual results:
As a result one have this (see screenshot attached) - 5-6 times the same poolid attached to the ak.

Expected results:
subscription should disappear after attaching to the activation key. Same for the case when it gets removed from activation key (it should get back appeared as available again!)

Additional info:
screenshot of the anomaly is attached.
Comment 4 Justin Sherrill 2014-05-30 15:05:05 EDT
This should be resolved with the new AK keys UI.
Comment 5 Justin Sherrill 2014-05-30 15:06:27 EDT
Confirmed this is resolved, moving to on_qa.
Comment 6 Sachin Ghai 2014-06-02 02:50:51 EDT
Verified with sat6 beta, snap7 compose2. 

I imported a manifest with 2 "RedHat Emplyee Subscriptions". I added both subscriptions one by one. Now If I add both of them to activation key then it disappears from "Add" tab. Similarly, if I remove both or any of them then again it appears under "Add" tab. I don't find any duplicacy or multiple additions of same subscription.

Looks like the reported issue is fixed. For verification, see the screenshots
Comment 7 Sachin Ghai 2014-06-02 02:53:04 EDT
Created attachment 901350 [details]
Remove tab shows both "Red Hat Employee Subscriptions"
Comment 8 Sachin Ghai 2014-06-02 02:54:41 EDT
Created attachment 901351 [details]
since both empolyee subscriptions are already added, so "Add" tab doesn't show any of them
Comment 9 Bryan Kearney 2014-07-02 10:09:59 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.
Comment 10 Bryan Kearney 2014-07-02 10:10:22 EDT
This was delivered in 6.0.3, the Beta version of Satellite 6.0
Comment 11 Bryan Kearney 2014-07-02 10:14:51 EDT
This was delivered in the Satellite 6 Beta (6.0.3)

Note You need to log in before you can comment on or make changes to this bug.