Bug 1021936 - Wrong icon target for shortcuts on windows if other language than English is used.
Wrong icon target for shortcuts on windows if other language than English is ...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ER3
: EAP 6.3.0
Assigned To: Miles Tjandrawidjaja
Petr Kremensky
Russell Dickenson
:
: 1090856 (view as bug list)
Depends On:
Blocks: 1040818
  Show dependency treegraph
 
Reported: 2013-10-22 07:05 EDT by Petr Kremensky
Modified: 2014-06-28 11:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
W2k8r2-x86_64 java version "1.7.0_40" Java(TM) SE Runtime Environment (build 1.7.0_40-b43) Java HotSpot(TM) Client VM (build 24.0-b56, mixed mode)
Last Closed: 2014-06-28 11:27:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kremensky 2013-10-22 07:05:58 EDT
Description of problem:
 Shortcuts have wrong icon target on windows if other language than English is used -> shotcuts have no icons.

Version-Release number of selected component (if applicable):
 EAP 6.2.0.ER6

How reproducible:
 Always

Steps to Reproduce:
 1. Run EAP installer (Console of GUI), choose other language than English.
 2. Choose to install shortcuts once asked (use default value or choose your own Program group name, but be aware of BZ1021901)
 3. Finish the installation 

Actual results:
 Targets for icons are:
$TARGET_DIR\jboss-eap-6.2\icons\48-start.png
$TARGET_DIR\jboss-eap-6.2\icons\48-stop.png
$TARGET_DIR\jboss-eap-6.2\icons\48-jmx.png
$TARGET_DIR\jboss-eap-6.2\icons\48-uninstall.png

Expected results:
 Targets for icons are:
$TARGET_DIR\jboss-eap-6.2\icons\48-start.ico
$TARGET_DIR\jboss-eap-6.2\icons\48-stop.ico
$TARGET_DIR\jboss-eap-6.2\icons\48-jmx.ico
$TARGET_DIR\jboss-eap-6.2\icons\48-uninstall.ico

Additional info:
 Shortcuts are working.
Comment 1 Miles Tjandrawidjaja 2013-10-22 11:52:05 EDT
Shortcuts have been updated to use .ico files on windows for all languages.

http://git.app.eng.bos.redhat.com/jbossas-installer.git/commit/?h=soa6&id=7055ce865ba86e26930aca5b48af9c94dd088a94
Comment 2 Petr Kremensky 2013-11-01 10:32:46 EDT
There is more I didn't notice before, but it can be seen in the commit you've provided. 

All shortcuts are pointing to *.sh scripts instead of *.bat ones.
Comment 3 Miles Tjandrawidjaja 2013-11-05 09:48:07 EST
Windows shortcuts now refer to *.bat files in all languages.

http://git.app.eng.bos.redhat.com/jbossas-installer.git/commit/?h=eap-6.2&id=e67d2916baefea53707aade3a5d4f00c10317b0f

Also ensured all shortcuts asks for admin rights before running. Otherwise server will not launch properly.

http://git.app.eng.bos.redhat.com/jbossas-installer.git/commit/?h=eap-6.2&id=f4a3d8b92f78e33ae636817a8c6b4791239739bf
Comment 4 Petr Kremensky 2013-11-15 08:29:59 EST
Shortcut icon are broken again. They were working with ER7.
Use eg. Deutsch to install EAP on windows. Server start shortcut icon is good, other shortcuts use:
$TARGET_DIR\jboss-eap-6.2\icons\48-stop.png
$TARGET_DIR\jboss-eap-6.2\icons\48-jmx.png
$TARGET_DIR\jboss-eap-6.2\icons\48-uninstall.png

Shortcut targets are broken either.
target for standalone administration is:
W:\pkremens\EAP-6.2.0\jboss-eap-6.2\bin\run.exe http://localhost:8080/console
target for standalone shutdown is: 
W:\pkremens\EAP-6.2.0\jboss-eap-6.2\bin\run.exe --connect command=:shutdown --controller=127.0.0.1:9999
...
Comment 5 Miles Tjandrawidjaja 2013-11-15 15:19:02 EST
Changed back to use icon files.

http://git.app.eng.bos.redhat.com/jbossas-installer.git/commit/?h=eap-6.2&id=e2679ac5c3f77e351cc017e4677599c6a920493f

Also note that shutting down server on windows will not work when installing to directory with spaces. Bug has been submitted.

See: https://bugzilla.redhat.com/show_bug.cgi?id=1031173
Comment 6 Petr Kremensky 2013-11-18 03:57:10 EST
Great catch with BZ1031173 I cannot believe we miss this.

You are using jboss-cli.sh script for server shutdown in: 
http://git.app.eng.bos.redhat.com/jbossas-installer.git/commit/?h=eap-6.2&id=e2679ac5c3f77e351cc017e4677599c6a920493f

I guess that batch script should be used instead.
Comment 7 Miles Tjandrawidjaja 2013-11-18 12:03:46 EST
Yes your right changed back to use .bat files.

http://git.app.eng.bos.redhat.com/jbossas-installer.git/commit/?h=eap-6.2&id=11d14fe524a1306115f78556affc1d807f9b0173
Comment 8 Petr Kremensky 2013-11-19 08:05:59 EST
This is still broken. Icons are fine now, but some shortcuts have wrong target.

Working shortcuts (English GUI installation):
 - Server start (standalone):
W:\pkremens\EAP-6.2.0\jboss-eap-6.2\bin\run.exe "W:\pkremens\EAP-6.2.0\jboss-eap-6.2\bin\standalone.bat"
 - Server start (domain):
W:\pkremens\EAP-6.2.0\jboss-eap-6.2\bin\run.exe "W:\pkremens\EAP-6.2.0\jboss-eap-6.2\bin\domain.bat"
 - Server administration (standalone):
C:\Windows\System32\cmd.exe /C start http:\\localhost:8080\console
 - Server administration (domain):
C:\Windows\System32\cmd.exe /C start http:\\localhost:9990\console
 - Server stop (standalone):
W:\pkremens\EAP-6.2.0\jboss-eap-6.2\bin\jboss-cli.bat --connect command=:shutdown --controller=127.0.0.1:9999
 - Server stop (domain):
W:\pkremens\EAP-6.2.0\jboss-eap-6.2\bin\jboss-cli.bat --connect command=/host=master:shutdown --controller=localhost:9999
 - Uninstallation:
W:\pkremens\jdk1.7.0_40\jre\bin\java.exe -jar "W:\pkremens\EAP-6.2.0\Uninstaller\uninstaller.jar"

Deutsch GUI installation:
 - Server start (standalone): different file separator is used, but working
W:\pkremens\EAP-6.2.0\jboss-eap-6.2\bin\run.exe "W:\pkremens\EAP-6.2.0/jboss-eap-6.2/bin/standalone.bat"
 - Server start (domain): different file separator is used, but working
W:\pkremens\EAP-6.2.0\jboss-eap-6.2\bin\run.exe "W:\pkremens\EAP-6.2.0/jboss-eap-6.2/bin/domain.bat"
 - Server administration (standalone): BROKEN
W:\pkremens\EAP-6.2.0\jboss-eap-6.2\bin\run.exe http://localhost:8080/console
 - Server administration (domain): BROKEN
W:\pkremens\EAP-6.2.0\jboss-eap-6.2\bin\run.exe http://localhost:9990/console
 - Server stop (standalone): OK
W:\pkremens\EAP-6.2.0\jboss-eap-6.2\bin\jboss-cli.bat --connect command=:shutdown --controller=127.0.0.1:9999
 - Server stop (domain): OK
W:\pkremens\EAP-6.2.0\jboss-eap-6.2\bin\jboss-cli.bat --connect command=/host=master:shutdown --controller=localhost:9999
 - Uninstallation: BROKEN
W:\pkremens\EAP-6.2.0\jboss-eap-6.2\bin\jboss-cli.bat -jar "W:\pkremens\EAP-6.2.0/Uninstaller/uninstaller.jar"
Comment 9 Miles Tjandrawidjaja 2013-11-19 10:01:12 EST
Fixing shortcuts so browser launches properly in other languages.

http://git.app.eng.bos.redhat.com/jbossas-installer.git/commit/?h=eap-6.2&id=b4751e86f65ac9a0c52c5e71ffbda5850712fa50
Comment 10 Petr Kremensky 2013-11-19 10:05:30 EST
Also uninstaller shortcut is broken!
Comment 11 Miles Tjandrawidjaja 2013-11-21 13:56:01 EST
For some reason the uninstaller shortcut definition has to be first or else it won't work. 

http://git.app.eng.bos.redhat.com/jbossas-installer.git/commit/?h=eap-6.2&id=20de1d990190adc779a9fa44d0d3844f78b3ea1c
Comment 12 Petr Kremensky 2013-11-22 08:07:12 EST
All shortcuts have correct target and icon. Verified on EAP 6.2.0.CR3 installer.
Comment 13 Petr Kremensky 2013-12-12 02:46:43 EST
I did some automation on this recently and there is still an issue with standalone start shortcut target after installing the EAP in French: 

java.lang.AssertionError: Wrong execution target for shortcut: Démarrer le serveur (autonome).lnk
Expected : c:\workspace\jbossqe-eap-tests-installer\target\eap\jboss-eap-6.2\bin\run.exe "c:\workspace\jbossqe-eap-tests-installer\target\eap\jboss-eap-6.2\bin\standalone.bat"
Actual   : c:\workspace\jbossqe-eap-tests-installer\target\eap\jboss-eap-6.2\bin\run.exe "c:\workspace\jbossqe-eap-tests-installer\target\eap/${common.gap.name}/bin/standalone.bat"

I also run into some non-functional things on windows which are causing my tests to fail (slashes instead of backslashes, ... ), I've created BZ1040818 to cover them.
Comment 14 Miles Tjandrawidjaja 2013-12-12 10:02:23 EST
http://git.app.eng.bos.redhat.com/jbossas-installer.git/commit/?h=eap-6.2&id=5c3379c9b2161663e05577126eff8f1747f0c27c

French shortcut should be as expected.
Comment 15 Petr Kremensky 2014-04-24 06:13:16 EDT
*** Bug 1090856 has been marked as a duplicate of this bug. ***
Comment 16 Petr Kremensky 2014-04-24 06:19:16 EDT
Increasing severity as shortcuts are broken again in EAP 6.3.0.ER2. 

See BZ1090856 description for more information.
Comment 17 Petr Kremensky 2014-04-24 06:20:22 EDT
Not only icons, but also targets are broken now.
Comment 18 Miles Tjandrawidjaja 2014-04-24 14:36:43 EDT
Looks like out configuration was modified after pulling from zanata. I've revert back to the original shortcut configurations, and shortcuts look to be working for non-english languages like Dutch, Japanese.

http://git.app.eng.bos.redhat.com/git/eap-installer.git/commit/?id=ff69c9e40c4b185a9ddd9eafd57e935a46e10134
Comment 19 Petr Kremensky 2014-05-05 06:27:14 EDT
Verified on EAP 6.3.0.ER3. Shortcuts are now properly created for all languages.

Note You need to log in before you can comment on or make changes to this bug.