Bug 1021993 - [RHSC] Remove-brick status is not displayed after clicking on the Status button in the remove-brick drop-down menu
[RHSC] Remove-brick status is not displayed after clicking on the Status butt...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity urgent
: ---
: RHGS 2.1.2
Assigned To: Ramesh N
Shruti Sampat
: Reopened, ZStream
Depends On: 1022946
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 08:59 EDT by Shruti Sampat
Modified: 2015-05-13 12:33 EDT (History)
8 users (show)

See Also:
Fixed In Version: cb8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:43:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rnachimu: needinfo-


Attachments (Terms of Use)
engine logs (8.03 MB, text/x-log)
2013-10-22 08:59 EDT, Shruti Sampat
no flags Details
vdsm logs - 1 (6.19 MB, text/x-log)
2013-10-22 09:14 EDT, Shruti Sampat
no flags Details
vdsm logs - 2 (13.60 MB, text/x-log)
2013-10-22 09:15 EDT, Shruti Sampat
no flags Details
vdsm logs - 3 (13.42 MB, text/x-log)
2013-10-22 09:19 EDT, Shruti Sampat
no flags Details
vdsm logs - 4 (13.78 MB, text/x-log)
2013-10-22 09:20 EDT, Shruti Sampat
no flags Details

  None (edit)
Description Shruti Sampat 2013-10-22 08:59:42 EDT
Created attachment 814975 [details]
engine logs

Description of problem:
-----------------------
After starting remove-brick on a volume, on clicking on Status button in the remove-brick drop-down menu in the Activities column, the status dialog does not show up.

The following error is seen in the engine logs -

2013-10-22 11:31:09,844 ERROR [org.ovirt.engine.core.bll.gluster.GetGlusterVolumeRemoveBricksStatusQuery] (ajp-/127.0.0.1:8702-6) Query GetGlusterVolumeRemoveBricksStatusQuery failed. Exception message is VdcBLLException: Command execution failed
error: Usage: volume remove-brick <VOLNAME> [replica <COUNT>] <BRICK> ... {start|stop|status|commit|force}
return code: 1 (Failed with error GlusterCmdExecFailedException and code 4105)

The volume is a 3x2 distributed-replicate volume, on which rebalance and remove-brick has been run multiple times.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.2-0.0.scratch.beta1.el6_4 

How reproducible:
Intermittent

Steps to Reproduce:
1. Start remove-brick on distributed-replicate volume.
2. Click on Status button in the remove-brick menu in the Activities column.

Actual results:
Status dialog does not show up.

Expected results:
Status dialog should be displayed.

Additional info:
Comment 1 Shruti Sampat 2013-10-22 09:14:13 EDT
Created attachment 814997 [details]
vdsm logs - 1
Comment 2 Shruti Sampat 2013-10-22 09:15:58 EDT
Created attachment 814998 [details]
vdsm logs - 2
Comment 3 Shruti Sampat 2013-10-22 09:19:18 EDT
Created attachment 815000 [details]
vdsm logs - 3
Comment 4 Shruti Sampat 2013-10-22 09:20:58 EDT
Created attachment 815001 [details]
vdsm logs - 4
Comment 6 Ramesh N 2013-10-24 06:00:55 EDT
Its no longer reproducible.
Comment 7 Shruti Sampat 2013-10-28 06:14:14 EDT
Not reproducible in Red Hat Storage Console Version: 2.1.2-0.21.beta1.el6_4. Closing with resolution CURRENTRELEASE.
Comment 8 Shruti Sampat 2013-11-13 09:03:41 EST
Hi,

I am seeing this again in Red Hat Storage Console Version: 2.1.2-0.23.master.el6_5. Re-opening the BZ.
Comment 9 Ramesh N 2013-11-14 01:21:24 EST
The actual issue reported in CB4 was due to a VDSM exception. It got fixed in CB5 already. Please attach latest Logs to analyze the issue further.
Comment 10 Ramesh N 2013-11-14 01:37:19 EST
Its the same as the issue reported in bug 1022946. Both rebalance and remove-brick status are using the same status dialog in UI.
Comment 11 Shruti Sampat 2013-11-19 04:48:14 EST
Verified as fixed in Red Hat Storage Console Version: 2.1.2-0.24.master.el6_5. Status dialog now appears correctly and displays the status.
Comment 12 Ramesh N 2014-01-03 06:55:08 EST
New feature hence no doc text required
Comment 14 errata-xmlrpc 2014-02-25 02:43:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.