Bug 1022030 - [firstboot] Should check if the system is already registered or not
[firstboot] Should check if the system is already registered or not
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2013-10-22 10:07 EDT by Rehana
Modified: 2014-01-17 15:25 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-17 15:25:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rehana 2013-10-22 10:07:51 EDT
Description of problem:
Observed that new firstboot screens on rhel7 doesnt not show any message if the system is already registered  

Version-Release number of selected component (if applicable):
subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.29-1
subscription-manager: 1.10.4-1.git.0.e94d2a9.el7
python-rhsm: 1.10.3-1.git.0.6ac2883.el7

How reproducible:
3/3

Steps to Reproduce:
1.Register system to candlepin server
2.launch firstboot


Actual results:
Observed that subscription registration section is not displaying

Expected results:
Should display subscription registration section with appropriate message like "system was registered for updates during installation" (or same as rhel6/rhel5 firstboot screen messages)

Additional info:
Comment 1 Devan Goodwin 2013-12-02 13:02:12 EST
Not sure this should be implemented. Firstboot is not intended to be run after the system is up, that is predominantly a development/QE thing. Firstboot is very difficult to maintain, adding complexity just for a dev/QE use-case seems like it may not be that worthwhile IMO.
Comment 2 Carter Kozak 2014-01-17 15:25:52 EST
Agree with comment 1.

Note You need to log in before you can comment on or make changes to this bug.