Bug 1022044 - packstack openstack-selinux install error: Error: Nothing to do
packstack openstack-selinux install error: Error: Nothing to do
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Martin Magr
Ami Jeain
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 10:29 EDT by wes hayutin
Modified: 2014-04-29 10:25 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.12.dev835.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-29 10:25:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log files from install (689.91 KB, application/octet-stream)
2013-10-22 10:29 EDT, wes hayutin
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 53159 None None None Never

  None (edit)
Description wes hayutin 2013-10-22 10:29:21 EDT
Created attachment 815021 [details]
log files from install

Description of problem:

======== END OF STDOUT ========
2013-10-22 09:48:46::DEBUG::sequences::48::root:: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 46, in run
    self.function(config)
  File "/usr/lib/python2.6/site-packages/packstack/plugins/puppet_950.py", line 182, in applyPuppetManifest
    waitforpuppet(currently_running)
  File "/usr/lib/python2.6/site-packages/packstack/plugins/puppet_950.py", line 167, in waitforpuppet
    validate_logfile(log)
  File "/usr/lib/python2.6/site-packages/packstack/modules/puppet.py", line 88, in validate_logfile
    raise PuppetError(message)
PuppetError: Error appeared during Puppet run: 192.168.200.227_prescript.pp
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-selinux' returned 1: Error: Nothing to do
You will find full trace in log /var/tmp/packstack/20131022-094539-GHveFT/manifests/192.168.200.227_prescript.pp.log
Comment 1 Martin Magr 2013-10-22 10:56:38 EDT
This basically means that there's no openstack-selinux package is available in yum repos. 

But such message should be "morphed" to message which gives some hint. What version of packstack has been used? On which version of Fedora has it been used?
Comment 2 wes hayutin 2013-10-22 11:04:59 EDT
RHEL 6.4 multi-node install
Oct 22 08:36:25 Installed: openstack-packstack-2013.2.1-0.11.dev806.el6.noarch

Yum logs attached, you can see openstack-selinux is installed.
The rpm must be available in the repo.

openstack-selinux-0.1.2-11.el6.noarch
Comment 3 Martin Magr 2013-10-22 11:24:48 EDT
According to /logs/rh-net-compute/log/yum.log it is not installed. So I guess 192.168.200.227 is rh-net-compute.
Comment 4 wes hayutin 2013-10-22 13:20:22 EDT
So what I believe is happening here is this...

If EPEL is not enabled in the packstack config, then the rdo-release rpm is not installed on any of the nodes. This is causing the openstack rpms not to be found on the additional node.
Comment 5 Martin Magr 2013-10-22 13:41:53 EDT
Ah yes, that's true. Currently RDO repo is only installed together with EPEL repo. This behaviour will be corrected with fix for bug #990642, eg. RDO repo will be installed on remote host automatically if it installed on host where packstack is running.

So this should be closed as NOTABUG, but since message has not been changed I will leave it open for the fix https://review.openstack.org/53159

Note You need to log in before you can comment on or make changes to this bug.