Bug 1022055 - Gluster commands hang after running the "gluster volume log rotate help" command
Gluster commands hang after running the "gluster volume log rotate help" command
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Unspecified
medium Severity medium
: ---
: ---
Assigned To: Krutika Dhananjay
:
Depends On: 1019504
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 10:51 EDT by Krutika Dhananjay
Modified: 2014-04-17 07:49 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1019504
Environment:
Last Closed: 2014-04-17 07:49:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2013-10-22 10:51:42 EDT
+++ This bug was initially created as a clone of Bug #1019504 +++

Description of problem:
After running the "gluster volume log rotate help" command, other "gluster ..." commands hang.

Version-Release number of selected component (if applicable):


How reproducible:
Consistently

Steps to Reproduce:
1. View the help information for the "log rotate" command.  It generates an error message and according to "gluster help", "gluster volume log rotate ..." is a valid command.

[root@rhsn1 ~]# gluster volume log rotate help
volume log-rotate: failed: Volume help does not exist

2. Any proceeding gluster command hangs.

[root@rhsn1 ~]# gluster volume info 

3. Restarting "glusterd" fixes the issue.

[root@rhsn1 ~]# service glusterd restart
Stopping glusterd:                                         [  OK  ]
Starting glusterd:                                         [  OK  ]

Actual results:
"gluster ..." commands hang.

Expected results:
glusterd must not hang when log rotate fails.

Additional info:
N/A
Comment 1 Anand Avati 2013-10-22 11:04:45 EDT
REVIEW: http://review.gluster.org/6122 (glusterd: Hold big-lock before invoking log-rotate handler) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Anand Avati 2013-10-23 10:29:26 EDT
REVIEW: http://review.gluster.org/6122 (glusterd: Release big-lock after log-rotate handler returns) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 3 Anand Avati 2013-10-30 06:14:46 EDT
REVIEW: http://review.gluster.org/6122 (glusterd: Release big-lock after log-rotate handler returns) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 4 Anand Avati 2013-10-30 06:43:37 EDT
REVIEW: http://review.gluster.org/6122 (glusterd: Release big-lock after log-rotate handler returns) posted (#4) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 5 Anand Avati 2013-10-31 01:19:25 EDT
COMMIT: http://review.gluster.org/6122 committed in master by Anand Avati (avati@redhat.com) 
------
commit 5e96e7d4a976975d8eac0bbf8d0d7ea663665bce
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Tue Oct 22 20:18:28 2013 +0530

    glusterd: Release big-lock after log-rotate handler returns
    
    ... so that subsequent volume commands don't block waiting forever,
    for the lock to be released.
    
    Change-Id: I24b5ec47f6982900ab74ff1b492d523f31ecfb7f
    BUG: 1022055
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/6122
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 6 Niels de Vos 2014-04-17 07:49:55 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.