This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1022060 - CPU model drop-down list is functional only for the first time opened
CPU model drop-down list is functional only for the first time opened
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 11:00 EDT by Kamil Páral
Modified: 2013-12-13 22:41 EST (History)
6 users (show)

See Also:
Fixed In Version: control-center-3.10.2-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-13 22:41:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug demonstration video (820.18 KB, video/webm)
2013-10-22 11:00 EDT, Kamil Páral
no flags Details
Simple python reproducer (409 bytes, text/plain)
2013-11-10 10:32 EST, Cole Robinson
no flags Details

  None (edit)
Description Kamil Páral 2013-10-22 11:00:26 EDT
Created attachment 815030 [details]
bug demonstration video

Description of problem:
Please see the video. The first time I open the CPU model drop-down list, I can scroll through all the items. But when I open it for the second time, the little top and bottom arrows disappear and I can't display off-screen items. Mouse scrolling doesn't help, neither manual keyboard arrow traversal.

If I close virt-manager (not just VM window, whole application) and start it again, then the drop-down list is functional again (for the first time).

Version-Release number of selected component (if applicable):
virt-manager-0.10.0-4.git79196cdf.fc20.noarch
gtk3-3.10.2-1.fc20.x86_64
gnome-shell-3.10.1-1.fc20.x86_64

How reproducible:
always

Steps to Reproduce:
1. open virt-manager
2. open VM properties
3. open CPU mode drop-down list
4. close the list and open it again
5. try to reach off-screen items
Comment 1 Giuseppe Scrivano 2013-11-10 09:52:19 EST
It seems to be related to pygtk.  I was able to reproduce it by a simpler python script.

I have reported it here: https://bugzilla.gnome.org/show_bug.cgi?id=711780
Comment 2 Cole Robinson 2013-11-10 10:32:13 EST
Created attachment 822103 [details]
Simple python reproducer

Seems to be a gtk issue, here's a simple reproducer using pygobject. It launches a window with a single ComboBox with a text entry. The combo is filled with enough items to require scrolling.

First click of the combobox arrow works correctly, subsequent clicks show the rows but no scroll arrows as demonstrated in Kamil's reproducer video.
Comment 3 Cole Robinson 2013-11-10 10:34:10 EST
(In reply to Giuseppe Scrivano from comment #1)
> It seems to be related to pygtk.  I was able to reproduce it by a simpler
> python script.
> 
> I have reported it here: https://bugzilla.gnome.org/show_bug.cgi?id=711780

Haha I missed your comment and implemented my script separately, glad we were on the same track :)
Comment 4 Matthias Clasen 2013-11-26 20:14:34 EST
Please try the gtk3 3.10.5 update that I've just built. It contains fixes for combobox sizing.
Comment 5 Kamil Páral 2013-11-27 06:10:14 EST
Thanks, gtk3-3.10.5-1.fc20.x86_64 fixes this issue.
Comment 6 Fedora Update System 2013-11-27 11:30:39 EST
control-center-3.10.2-3.fc20, gnome-settings-daemon-3.10.2-3.fc20, gtk3-3.10.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-22262/gtk3-3.10.5-1.fc20,control-center-3.10.2-3.fc20,gnome-settings-daemon-3.10.2-3.fc20
Comment 7 Fedora Update System 2013-12-13 22:41:11 EST
control-center-3.10.2-3.fc20, gnome-settings-daemon-3.10.2-3.fc20, gtk3-3.10.5-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.