Bug 1022160 - Can't open file '/var/spool/abrt/oops-2013-10-22-11:36:18-767-1/uid': No such file or directory
Can't open file '/var/spool/abrt/oops-2013-10-22-11:36:18-767-1/uid': No such...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt (Show other bugs)
6.4
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Jakub Filak
Martin Kyral
:
Depends On:
Blocks: 1056252
  Show dependency treegraph
 
Reported: 2013-10-22 11:52 EDT by Lukas Zachar
Modified: 2016-11-30 19:45 EST (History)
6 users (show)

See Also:
Fixed In Version: abrt-2.0.8-22.el6
Doc Type: Bug Fix
Doc Text:
no docs needed
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 04:05:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch fixing this issue (877 bytes, patch)
2014-06-18 04:40 EDT, Jakub Filak
no flags Details | Diff

  None (edit)
Description Lukas Zachar 2013-10-22 11:52:54 EDT
Description of problem:

When kerneloops is processed, following error is always found in /var/log/messages.
abrtd: Can't open file '/var/spool/abrt/oops-2013-10-22-11:20:51-5231-1/uid': No such file or directory

Version-Release number of selected component (if applicable):
abrt-2.0.8-16.el6_4.1.x86_64
abrt-addon-kerneloops-2.0.8-16.el6_4.1.x86_64


How reproducible:
always

Steps to Reproduce:
1. create kernel oops, e.g. by will_oops or writing to /var/log/messages
2. check /var/log/messages
3.

Actual results:
Oct 22 11:20:51 dell-pem610-01 abrtd: Directory 'oops-2013-10-22-11:20:51-5231-1' creation detected
Oct 22 11:20:51 dell-pem610-01 abrt-dump-oops: Reported 1 kernel oopses to Abrt
Oct 22 11:20:51 dell-pem610-01 abrtd: Can't open file '/var/spool/abrt/oops-2013-10-22-11:20:51-5231-1/uid': No such file or directory


Expected results:
No error from abrtd

Additional info:
Comment 4 hsudoh 2014-03-14 00:09:22 EDT
I encounter the same problem in RHEL6.2 x64 system.
Is this a bug ?
If so, could you provide the fix plan ??
Comment 5 hsudoh 2014-03-14 01:01:37 EDT
Does this message appear when Network problem occurs ??
Comment 6 Jakub Filak 2014-03-14 04:08:23 EDT
(In reply to hsudoh from comment #4)
> I encounter the same problem in RHEL6.2 x64 system.
> Is this a bug ?
> If so, could you provide the fix plan ??

This is not a bug. It is just an useless and disturbing debug message. Sorry for frightening you.
Comment 7 Jakub Filak 2014-03-14 04:18:05 EDT
(In reply to hsudoh from comment #5)
> Does this message appear when Network problem occurs ??

This message appears always when you experience a kernel oops. The kernel oops which produced the message could break Kernel's Network features. So yes, it might be connected to Network problems but as a consequence.

You should see the detected kernel oopses by issuing the following command:

$ abrt-cli list
Comment 8 hsudoh 2014-03-14 06:16:44 EDT
(In reply to Jakub Filak from comment #7)
> (In reply to hsudoh from comment #5)
> > Does this message appear when Network problem occurs ??
> 
> This message appears always when you experience a kernel oops. The kernel
> oops which produced the message could break Kernel's Network features. So
> yes, it might be connected to Network problems but as a consequence.
> 
> You should see the detected kernel oopses by issuing the following command:
> 
> $ abrt-cli list

Thank you for your information.
This message appeared when our customer was configuring 10G network.
I will investigate customer's network configuration.
Comment 9 Jakub Filak 2014-06-18 04:40:42 EDT
Created attachment 909879 [details]
A patch fixing this issue
Comment 12 errata-xmlrpc 2014-10-14 04:05:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1572.html

Note You need to log in before you can comment on or make changes to this bug.