Bug 1022183 - Adding certain ISOs to RHEV-M, it is not seen in the ISO list
Adding certain ISOs to RHEV-M, it is not seen in the ISO list
Status: CLOSED DUPLICATE of bug 1009484
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Sergey Gotliv
Pavel Stehlik
storage
: Regression, Reopened, TestBlocker, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 12:15 EDT by Bill Sanford
Modified: 2016-02-10 15:21 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-24 05:40:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: Triaged+


Attachments (Terms of Use)
The engine.log file from the RHEV-M server (1.01 MB, text/x-log)
2013-10-22 15:45 EDT, Bill Sanford
no flags Details

  None (edit)
Description Bill Sanford 2013-10-22 12:15:34 EDT
Description of problem:
Adding RHEL4-RC-re0107.0-x86_64-variant-src-DVD.iso to RHEV-M 3.3, it is not available in the list of ISOs.

http://download.lab.bos.redhat.com/released/RHEL-4/RC/ES/x86_64/src-isos/RHEL4-RC-re0107.0-x86_64-variant-src-DVD.iso

Version-Release number of selected component (if applicable):
RHEV-M 3.3 (is19)

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Bill Sanford 2013-10-22 13:24:58 EDT
It also fails to populate in the list with:

http://download.lab.bos.redhat.com/released/RHEL-4/RC/ES/x86_64/RHEL4-RC-re0107.0-x86_64-ES-DVD-ftp.iso
Comment 2 Bill Sanford 2013-10-22 13:26:04 EDT
The output of the ls -lat command:

[root@ns1 11111111-1111-1111-1111-111111111111]# ls -lat
total 34245072
drwxr-xr-x. 2 36 36       4096 Oct 22 13:19 .
-rw-r--r--. 1 36 36 2359482368 Oct 22 13:04 RHEL4-RC-re0107.0-x86_64-ES-DVD-ftp.iso
-rw-r--r--. 1 36 36 2902501376 Oct 22 11:31 en_windows_8_1_enterprise_x86_dvd_2972289.iso
-rw-------. 1 36 36 3798214656 Oct 22 09:32 en_windows_8_1_enterprise_x64_dvd_2791088.iso
-rw-r--r--. 1 36 36  295997440 Oct 16 15:28 RHEV-toolsSetup_3.3_6.iso
-rw-r--r--. 1 36 36  295915520 Aug 30 14:03 RHEV-toolsSetup_3.3_5.iso
-rw-r--r--. 1 36 36  261535744 Jul 15 15:44 RHEV-toolsSetup_3.2_8.iso
-rw-r--r--. 1 36 36 3695179776 Apr 29 10:29 en_windows_server_2012_x64_dvd_915478.iso
-rw-r--r--. 1 36 36  806676480 Mar 25  2013 OfficeProfessionalPlus_x64_en-us.iso
-rw-r--r--. 1 36 36 3720347648 Feb 12  2013 RHEL6.4-20130130.0-Server-x86_64-DVD1.iso
-rw-r--r--. 1 36 36 3581853696 Sep  6  2012 en_windows_8_x64_dvd_915440.iso
-rw-r--r--. 1 36 36 3679453184 Aug 21  2012 RHEL6.3-20120613.2-Server-x86_64-DVD1.iso
-rw-r--r--. 1 36 36 3166584832 Dec  8  2011 en_windows_server_2008_r2_with_sp1_x64_dvd_617601.iso
drwxr-xr-x. 3 36 36       4096 Sep 27  2011 ..
-rw-r--r--. 1 36 36  617756672 Aug  1  2011 en_windows_xp_professional_with_service_pack_3_x86_cd_x14-80428.iso
-rw-r--r--. 1 36 36 3320903680 Jun 30  2011 en_windows_7_professional_with_sp1_x64_dvd_u_676939.iso
-rw-r--r--. 1 36 36 2564476928 Jun 30  2011 en_windows_7_professional_with_sp1_x86_dvd_u_677056.iso
Comment 3 Itamar Heim 2013-10-22 15:28:46 EDT
errors in the engine log?
did you click the refresh button on the storage domain?
does restarting the engine has any effect?
Comment 4 Bill Sanford 2013-10-22 15:45:17 EDT
Created attachment 815167 [details]
The engine.log file from the RHEV-M server
Comment 6 Sergey Gotliv 2013-10-23 09:22:08 EDT

*** This bug has been marked as a duplicate of bug 1009484 ***
Comment 7 Bill Sanford 2013-10-23 10:23:51 EDT
I have copied certain files without the ISO uploader and they DO get seen in the list, only RHEL 4 was the issue in the original post.

Now this is including Windows 8.1. I have added Windows 8 and it adds to the ISO storage just fine.
Comment 8 Bill Sanford 2013-10-23 10:31:57 EDT
Sergey,

The ISO directory for me is not local, it is on a RHEL 6 server that also is my DCHP/DNS server. The mount command there is:

[root@ns1 ~]# mount
/dev/mapper/vg_dhcp47103-lv_root on / type ext4 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw,rootcontext="system_u:object_r:tmpfs_t:s0")
/dev/sda1 on /boot type ext4 (rw)
/dev/mapper/vg_dhcp47103-lv_home on /rhev type ext4 (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
nfsd on /proc/fs/nfsd type nfsd (rw)

The one I am mounting is:
/dev/mapper/vg_dhcp47103-lv_home on /rhev type ext4 (rw)

Everything from /rhev down has 36:36 for owner/group attribute.
Comment 11 Bill Sanford 2013-10-23 12:16:48 EDT
Sergey, from one of the hosts, the mount command:

[root@salusa ~]# mount
/dev/mapper/vg_salusa-lv_root on / type ext4 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw,rootcontext="system_u:object_r:tmpfs_t:s0")
/dev/mapper/1ATA_WDC_WD6400AAKS-22A7B2_WD-WCASYC833778p1 on /boot type ext4 (rw)
/dev/mapper/vg_salusa-lv_home on /home type ext4 (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
10.19.168.10:/rhev/isos on /rhev/data-center/mnt/10.19.168.10:_rhev_isos type nfs (rw,soft,nosharecache,timeo=600,retrans=6,nfsvers=3,addr=10.19.168.10)
/dev/mapper/3bf77a26--3a5a--4d29--8952--31e98dcc4753-master on /rhev/data-center/mnt/blockSD/3bf77a26-3a5a-4d29-8952-31e98dcc4753/master type ext3 (rw)
[root@salusa ~]# 

This is the mount to the ISO Storage:
10.19.168.10:/rhev/isos on /rhev/data-center/mnt/10.19.168.10:_rhev_isos type nfs (rw,soft,nosharecache,timeo=600,retrans=6,nfsvers=3,addr=10.19.168.10)


I am using RHEV-M 3.3 (is19), RHEL 6.5 snap 3 (RHEL6.5-20131009.0) for RHEV-M and hosts.

Note You need to log in before you can comment on or make changes to this bug.