Bug 1022250 - Newest Abiword fails to offer all available printers
Newest Abiword fails to offer all available printers
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abiword (Show other bugs)
20
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Marc Maurer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 16:24 EDT by Steven Usdansky
Modified: 2014-10-06 10:09 EDT (History)
3 users (show)

See Also:
Fixed In Version: libgsf-1.14.28-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-23 14:37:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Usdansky 2013-10-22 16:24:35 EDT
Description of problem:
Abiword only offers print to file; no print to printer

Version-Release number of selected component (if applicable):
abiword-3.0.0-2.fc20.x86_64
libabiword-3.0.0-2.fc20.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Start abiword
2. Select File->Print


Actual results:
Offers only print to file

Expected results:
A list of all available printers

Additional info:
Same problem with abiword-3.0.0-1.fc21; no problem with abiword-2.8.6-22.fc19.
Printer list appears properly in firefox, and geany
Comment 1 Peter Robinson 2013-11-10 17:51:14 EST
I get a list of all printers configured. It's the same as I get from other gtk3 apps. If you try and print from something like evince which will use the gtk3 print functionality do you get a different list?
Comment 2 Fedora Update System 2013-11-18 15:00:56 EST
libgsf-1.14.28-1.fc19,abiword-3.0.0-4.fc19,sugar-write-94-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libgsf-1.14.28-1.fc19,abiword-3.0.0-4.fc19,sugar-write-94-1.fc19
Comment 3 Fedora Update System 2013-11-19 00:29:45 EST
Package libgsf-1.14.28-1.fc19, abiword-3.0.0-4.fc19, sugar-write-94-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libgsf-1.14.28-1.fc19 abiword-3.0.0-4.fc19 sugar-write-94-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21665/libgsf-1.14.28-1.fc19,abiword-3.0.0-4.fc19,sugar-write-94-1.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-11-23 14:37:08 EST
libgsf-1.14.28-1.fc19, abiword-3.0.0-4.fc19, sugar-write-94-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Steven Usdansky 2014-10-06 10:09:38 EDT
Update works for me. Bug is marked closed; wondering why am I still receiving notifications?

Note You need to log in before you can comment on or make changes to this bug.