Bug 1022277 - LVM resource-agent fails to log error with unsupported usage
LVM resource-agent fails to log error with unsupported usage
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: resource-agents (Show other bugs)
6.6
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: David Vossel
Cluster QE
: EasyFix
: 1038264 (view as bug list)
Depends On:
Blocks: 1038264
  Show dependency treegraph
 
Reported: 2013-10-22 18:08 EDT by David Vossel
Modified: 2014-10-14 00:59 EDT (History)
4 users (show)

See Also:
Fixed In Version: resource-agents-3.9.2-45.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 00:59:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lvm log message fixes v1 (756 bytes, patch)
2014-04-02 16:13 EDT, David Vossel
no flags Details | Diff

  None (edit)
Description David Vossel 2013-10-22 18:08:58 EDT
Description of problem:

The pacemaker LVM agent under the heartbeat provide does not support exclusive activation with clvmd.  There's a log message that is supposed to be displayed indicating this condition, but there is a syntax error in the log message that prevents it from being output.

Version-Release number of selected component (if applicable):

3.9.2-21.el6_4.8

How reproducible:

100%

Steps to Reproduce:
1.start clvmd
2. attempt to activate a cluster volume group with exclusive activation
3. error message indicating why the agent can not proceed with the activation is not output.

Actual results:

line 597: ocf_log_err: command not found

Expected results:

"Exclusive activation via clvmd is not supported by this agent"


Additional info:

doing a search and replace of "s/ocf_log_err/ocf_log err/g" will fix this.
Comment 2 David Vossel 2014-04-02 15:58:56 EDT
upstream patch.

https://github.com/ClusterLabs/resource-agents/commit/bb58a4c9
Comment 3 David Vossel 2014-04-02 16:13:01 EDT
Created attachment 881983 [details]
lvm log message fixes v1

This patch fixes another LVM log message that was not in the upstream patch.
Comment 4 David Vossel 2014-04-02 16:14:43 EDT
*** Bug 1038264 has been marked as a duplicate of this bug. ***
Comment 6 michal novacek 2014-05-13 09:24:29 EDT
I have verified that there are no more occurences of 'ocf_log_err' in any of the resource-agents.
Comment 7 errata-xmlrpc 2014-10-14 00:59:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1428.html

Note You need to log in before you can comment on or make changes to this bug.