Bug 102233 - LTC3891-RHN Update Agent fails to update gcc; kernel-source package can't be installed
LTC3891-RHN Update Agent fails to update gcc; kernel-source package can't be ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: up2date (Show other bugs)
2.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-12 16:33 EDT by IBM Bug Proxy
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-23 14:44:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2003-08-12 16:33:55 EDT
The following has be reported by IBM LTC:  
RHN Update Agent fails to update gcc; kernel-source package can't be installed
Please fill in each of the sections below.

Hardware Environment:
xSeries 370
6 x Intel Pentium III Xeon 700MHz
3 GB RAM

Software Environment:
Red Hat Linux Advanced Server 2.1

Steps to Reproduce:
1. download e-25 source rpm from RHN
2. use Update Agent to update system to latest software levels

Here, I noticed (using rpm -qa | grep 'kernel') that no -source rpms were
installed. Then I attempted to install the e-25 source, and I received an error:

gcc >= 2.96-85 is needed by kernel-source-2.4.9-e.25

I would have thought that the Update Agent would either have installed the
correct version of gcc.

Note: attepmting to install the gcc rpm (which should have been updated by the
Update Agent, IMO) finds more broken dependencies. This is true even after a reboot.

Actual Results:

Expected Results:

Additional Information:Glen/Greg - this is a bug against the RHN Update Agent. 
Please submit this
to Red Hat.  Thanks.
Comment 1 Adrian Likins 2003-08-13 23:24:05 EDT
Not sure I understand whats going on here. AS2.1 ships with
gcc-2.96-108.1, which is newer than the require you mention. 

So _if_ it is installed, it should be new enough.

Verify that gcc is installed. 
Comment 2 Adrian Likins 2004-08-23 14:44:00 EDT
closing, no response to NEEDINFO

shouldnt be an issue in current releases as well

Note You need to log in before you can comment on or make changes to this bug.