Bug 1022338 - rhsc-setup fails with "cannot import name redhatsupportplugin"
rhsc-setup fails with "cannot import name redhatsupportplugin"
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: redhat-access-plugin-rhsc (Show other bugs)
Unspecified Unspecified
high Severity high
: ---
: RHGS 2.1.2
Assigned To: Spenser Shumaker
: ZStream
Depends On:
  Show dependency treegraph
Reported: 2013-10-23 01:44 EDT by Sahina Bose
Modified: 2015-05-15 14:20 EDT (History)
11 users (show)

See Also:
Fixed In Version: redhat-access-plugin-rhsc-2.1.2-2.el6rhs.noarch
Doc Type: Bug Fix
Doc Text:
Previously, rhsc-setup command was failing and an error message that the redhatsupportplugin cannot be installed was displayed. Now, with this update, the import path for redhatsupportplugin is updated and the rhsc-setup command runs successfully.
Story Points: ---
Clone Of:
Last Closed: 2014-02-25 02:43:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Sahina Bose 2013-10-23 01:44:27 EDT
Description of problem:

Install redhat-access-plugin-storage from https://brewweb.devel.redhat.com/buildinfo?buildID=292535.

 After installing this with recent rhsc build, "rhsc-setup" gives following error

 [root@localhost rhsc_rpms]# rhsc-setup
***L:ERROR Internal error: cannot import name redhatsupportplugin

 Some details about the installation

 [root@localhost rhsc_rpms]# ls -l /usr/share/ovirt-engine/setup/plugins/ovirt-engine-setup/redhat-access-plugin-storage/
total 40
-rw-r--r--. 1 root root  862 Aug 29 21:49 __init__.py
-rw-r--r--. 2 root root  620 Aug 29 21:49 __init__.pyc
-rw-r--r--. 2 root root  620 Aug 29 21:49 __init__.pyo
-rw-r--r--. 1 root root 8258 Aug 29 21:49 redhat-access-plugin-storage.py
-rw-r--r--. 2 root root 6626 Aug 29 21:49 redhat-access-plugin-storage.pyc
-rw-r--r--. 2 root root 6626 Aug 29 21:49 redhat-access-plugin-storage.pyo

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
As above
Comment 4 Prasanth 2013-12-16 08:58:56 EST
Sahina/Spencer, please fill in the Fixed In Version for this bug.
Comment 5 Prasanth 2013-12-18 08:33:12 EST
Verified as fixed in redhat-access-plugin-rhsc-2.1.2-2.el6rhs.noarch

rhsc-setup now completes successfully.
Comment 6 Shalaka 2014-01-21 01:19:14 EST
Please review the edited DocText and signoff.
Comment 7 Sahina Bose 2014-01-21 03:13:40 EST
Looks ok
Comment 9 errata-xmlrpc 2014-02-25 02:43:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.