Bug 1022356 - fail to run `perl rh-database-update.pl` twice
fail to run `perl rh-database-update.pl` twice
Status: CLOSED DUPLICATE of bug 917935
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 02:53 EDT by matt jia
Modified: 2013-11-11 05:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 05:54:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description matt jia 2013-10-23 02:53:31 EDT
Description of problem:

fail to run `perl rh-database-update.pl` twice

Version-Release number of selected component (if applicable):
4.4

How reproducible:

run `perl rh-database-update.pl` twice

Actual results:

# perl rh-database-update.pl 
Adding new table bz_schema...
Initializing bz_schema...
Table already exists: bz_schema at Bugzilla/DB/Schema.pm line 2589.

It tries to add the table twice and blows up

Expected results:

It should not add the table when the table exists

Additional info:
Comment 1 Simon Green 2013-11-11 05:54:34 EST

*** This bug has been marked as a duplicate of bug 917935 ***

Note You need to log in before you can comment on or make changes to this bug.