This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1022375 - Miss create "Data" logical volume when using the default value of "Data" in storage_vol_page
Miss create "Data" logical volume when using the default value of "Data" in s...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: Regression
Depends On: 1000272
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 03:39 EDT by haiyang,dong
Modified: 2014-01-21 14:55 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-10.el6
Doc Type: Bug Fix
Doc Text:
Previously, the storage volume space retrieved the default value for the data volume size from ovirtfunctions. This resulted in the data volume size being set as -1 on the first run and displaying properly while leaving the model size set to 0. Now, a default size of 0 is returned when running the TUI installer, so the volume is properly created.
Story Points: ---
Clone Of: 1000272
Environment:
Last Closed: 2014-01-21 14:55:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19857 None None None Never

  None (edit)
Description haiyang,dong 2013-10-23 03:39:47 EDT
+++ This bug was initially created as a clone of Bug #1000272 +++

Description of problem:
boot ovirt-node-iso-3.1.0-0.999.999.20130822204541gitb3a1a44.284.fc18.iso, after enter into storage_vol_page,
didn't change any item values of storage_vol_page, just using the default values to partition.
But Miss create "Data" logical volume when using the default value of "Data" in  storage_vol_page(lvs.png)

no this issue when using custom "Data" value to create "Data" logical volume.

 


Version-Release number of selected component (if applicable):
ovirt-node-iso-3.1.0-0.999.999.20130822204541gitb3a1a44.284.fc18.iso

How reproducible:
100% 
 
Steps to Reproduce:

Actual result:
Miss create "Data" logical volume when using the default value of "Data" in  storage_vol_page

Expect result:
create "Data" logical volume  success when using the default value of "Data" in  storage_vol_page

Additional info:
Comment 5 haiyang,dong 2013-10-26 07:40:50 EDT
Test version:
rhevh-6.5-20131024.1.0.iso
ovirt-node-3.0.1-6.el6.noarch

Test steps:
1. Boot ISO and let the installer start
2. Keep the default (let the data lv grab all remainaing space)
3. Let the installer finish
4. Drop to shell and check that the Data LV exists.
$ lvs
  LV      VG     Attr       LSize   Pool Origin Data%  Move Log Cpy%Sync Convert
  Config  HostVG -wi-ao----   8.00m                                             
  Data    HostVG -wi-ao---- 287.58g                                             
  Logging HostVG -wi-ao----   2.00g                                             
  Swap    HostVG -wi-ao----   7.79g

1. Boot ISO and let the installer start
2. Set a custom Data size (e.g. 2048)
3. Let the installer finish
4. Drop to shell and check that the Data LV exists and has approx. the correct size:
$ lvs
  LV      VG     Attr       LSize Pool Origin Data%  Move Log Cpy%Sync Convert
  Config  HostVG -wi-ao---- 8.00m                                             
  Data    HostVG -wi-ao---- 2.00g                                             
  Logging HostVG -wi-ao---- 2.00g                                             
  Swap    HostVG -wi-ao---- 2.43g 

so this bug has been fixed, change it into "VERIFIED".
Comment 6 haiyang,dong 2013-12-13 01:03:53 EST
Met this issue on version ovirt-node-3.0.1-8.el6_5.noarch.rpm, so need to re-assigned this bug. Also it's a regression bug from ovirt-node-3.0.1-6.el6.noarch to ovirt-node-3.0.1-8.el6_5.noarch.
Comment 9 haiyang,dong 2013-12-22 20:49:28 EST
Test version:
rhevh-6.5-20131220.0.iso
ovirt-node-3.0.1-13.el6_5.noarch

Test steps:
1. Boot ISO and let the installer start
2. Keep the default (let the data lv grab all remainaing space)
3. Let the installer finish
4. Drop to shell and check that the Data LV exists.
$ lvs
  LV      VG     Attr       LSize Pool Origin Data%  Move Log Cpy%Sync Convert
  Config  HostVG -wi-ao---- 8.00m                                             
  Data    HostVG -wi-ao---- 8.82g                                             
  Logging HostVG -wi-ao---- 2.00g                                             
  Swap    HostVG -wi-ao---- 2.43g  

1. Boot ISO and let the installer start
2. Set a custom Data size (e.g. 2048)
3. Let the installer finish
4. Drop to shell and check that the Data LV exists and has approx. the correct size:
$ lvs
   LV      VG     Attr       LSize Pool Origin Data%  Move Log Cpy%Sync Convert
  Config  HostVG -wi-ao---- 8.00m                                             
  Data    HostVG -wi-ao---- 2.00g                                             
  Logging HostVG -wi-ao---- 2.00g                                             
  Swap    HostVG -wi-ao---- 2.43g   

1. Boot ISO and let the installer start
2. Set a custom Data size (e.g. 0)
3. Let the installer finish
4. Drop to shell and check that the Data LV exists and has approx. the correct size:
$ lvs
  LV      VG     Attr       LSize Pool Origin Data%  Move Log Cpy%Sync Convert
  Config  HostVG -wi-ao---- 8.00m                                             
  Logging HostVG -wi-ao---- 2.00g                                             
  Swap    HostVG -wi-ao---- 2.43g 

so this bug has been fixed, after the status of this bug changed into "ON_QA", I'll verify it.
Comment 10 haiyang,dong 2013-12-23 21:28:30 EST
According to comment 9, change the status into "verified".
Comment 11 haiyang,dong 2014-01-20 05:14:13 EST
Also this bug was fixed in the follow version:
rhevh-6.5-20140110.1
ovirt-node-3.0.1-16.el6_5.noarch
Comment 13 errata-xmlrpc 2014-01-21 14:55:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.