This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1022435 - Throw "argument 1 must be Entity, not None" exception when setting cim password
Throw "argument 1 must be Entity, not None" exception when setting cim password
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Ryan Barry
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 05:39 EDT by haiyang,dong
Modified: 2014-01-21 14:35 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-8.el6
Doc Type: Bug Fix
Doc Text:
The '%post scriptlet' was failing, which meant that the cim user did not get created, and the password could not be set in the TUI. This was caused by a code error and is now fixed, meaning the cim user is created and the password can be set.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:35:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached Screenshot for cim transaction page (6.69 KB, image/png)
2013-10-23 05:39 EDT, haiyang,dong
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20435 None None None Never

  None (edit)
Description haiyang,dong 2013-10-23 05:39:02 EDT
Created attachment 815299 [details]
attached Screenshot for cim transaction page

Description of problem:
Clean install rhev-hypervisor6-6.5-20131017.0.auto2095.el6.iso and enter into cim page,
enabled cim and set cim password, but throw "argument 1 must be Entity,not None" exception 
when setting cim password(seen cim transaction page.png) 

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20131017.0.auto2095.el6.iso

How reproducible:
100%

Steps to Reproduce:

Actual results:


Expected results:


Additional info:
Comment 4 haiyang,dong 2013-12-17 04:39:29 EST
Test version:
ovirt-node-3.0.1-9.el6_5.noarch.rpm
rhevh-6.5-20131213.0.0.iso

enter into cim page,
enabled cim and set cim password, click "Save" button to configure cim success,
also cim function can work.

so this bug has been fixed on ovirt-node-3.0.1-9.el6_5, after the status of this bug changed into "ON_QA", I will verify it.
Comment 5 haiyang,dong 2013-12-19 21:10:55 EST
According to comment 4 , change the status into "verified"
Comment 6 Cheryn Tan 2014-01-08 00:35:28 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thank you for your help.
Comment 7 Charlie 2014-01-14 18:36:29 EST
Hi could you let me know what the problem was and what the fix was for the doc text? Thanks.
Comment 8 Ryan Barry 2014-01-14 19:55:19 EST
This bug was a duplicate of 1024672, basically. Because the %post scriptlet failed, the cim user did not get created, and the password could not be set in the TUI.
Comment 9 haiyang,dong 2014-01-20 04:46:45 EST
Also this bug was fixed in the follow version:
rhevh-6.5-20140110.1
ovirt-node-3.0.1-16.el6_5.noarch
Comment 11 errata-xmlrpc 2014-01-21 14:35:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.