Bug 102246 - Update to 2.1.20, separate -devel subpackage, enhancements, compatibility
Summary: Update to 2.1.20, separate -devel subpackage, enhancements, compatibility
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: gkrellm   
(Show other bugs)
Version: beta1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-12 21:42 UTC by Ville Skyttä
Modified: 2007-04-18 16:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-09 11:27:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Suggested specfile patch (4.31 KB, patch)
2003-08-12 21:44 UTC, Ville Skyttä
no flags Details | Diff
Update to 2.1.20, bring up to date against current rawhide (4.32 KB, patch)
2003-10-08 20:55 UTC, Ville Skyttä
no flags Details | Diff

Description Ville Skyttä 2003-08-12 21:42:53 UTC
I will submit a proposed patch to the gkrellm specfile.  More details in the
included %changelog.  The compatibility part is for smoothly upgrading from
external 3rd party repository packages such as freshrpms.net and www.fedora.us.

Comment 1 Ville Skyttä 2003-08-12 21:44:26 UTC
Created attachment 93609 [details]
Suggested specfile patch

Note: this patch is in UTF-8.  More information available on request, but the
changes should be self-explanatory.

Note #2:  /usr/bin/gkrellmd should be changed to /usr/sbin/gkrellmd in
gkrellmd.init after applying this patch.

Comment 2 Ville Skyttä 2003-09-12 20:38:20 UTC
GKrellM 2.1.19 is out.  The attached patch still works just by doing a simple
s/2.1.15/2.1.19/.  Please consider applying/updating this.

Comment 3 Ville Skyttä 2003-10-08 20:55:40 UTC
Created attachment 95027 [details]
Update to 2.1.20, bring up to date against current rawhide

I see gkrellm has been updated to 2.1.19, but this issue has been ignored so
far.
Attached is the same patch updated to apply cleanly against 2.1.19-1 in
Rawhide.

Would it be possible to get some feedback/comments on this?  TIA.

Comment 4 Ville Skyttä 2003-10-08 20:57:41 UTC
Note #2 from comment 1 still applies with the updated patch wrt the gkrellmd
location.

Comment 5 Karsten Hopp 2003-10-09 11:27:11 UTC
Most of your suggestions are now in gkrellm-2.1.20-2.  
The -devel subpackage has to wait for the next release as we are currently in string freeze 
(because of the translations) and can't add new strings such as the package description. 
 

Comment 6 Ville Skyttä 2003-10-09 17:36:13 UTC
Thanks.

About the -devel package; would it be possible to add a "Provides:
gkrellm-devel" in the main package in the meantime?  That would make this
package compatible with a lot of plugin packages out there which have
"BuildRequires: gkrellm-devel"?


Comment 7 Karsten Hopp 2003-10-09 18:50:38 UTC
sure, no problem. Done in -3 

Comment 8 Ville Skyttä 2003-10-09 19:43:10 UTC
Wonderful, thanks a bunch!


Note You need to log in before you can comment on or make changes to this bug.