Bug 1022467 - guest need to reboot two times after complete installation
guest need to reboot two times after complete installation
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 06:51 EDT by Sibiao Luo
Modified: 2013-10-24 00:59 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-24 00:59:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sibiao Luo 2013-10-23 06:51:02 EDT
Description of problem:
instll guest with Desktop, and hit 'Reboot' button, then need to configurate it after reboot, but then guest will need reboot again after hit 'Finish' button, It should login guest directly after complete installation, no need to reboot again.

Version-Release number of selected component (if applicable):
host info:
# uname -r && rpm -q qemu-kvm
2.6.32-424.el6.x86_64
qemu-kvm-0.12.1.2-2.414.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.instll guest with Desktop.
2.hit 'Reboot' button after installation.
3.go to configuration welcome page and agree the license to setup your system.
4.hit 'Finish' to complete your configuration.

Actual results:
after step 4, guest need to reboot again, then to the login page.

Expected results:
guest should no need to reboot again after complete installation, it can get to the login page directly.

Additional info:
Comment 3 Sibiao Luo 2013-10-24 00:52:48 EDT
Tried the qemu-kvm-0.12.1.2-2.355.el6.x86_64 that also hit the same issue.
host info:
# uname -r && rpm -q qemu-kvm
2.6.32-424.el6.x86_64
qemu-kvm-0.12.1.2-2.355.el6.x86_64
Comment 4 Sibiao Luo 2013-10-24 00:59:51 EDT
Also tried if did not enable kdump during in configuration, guest did not need to reboot again. Ennable kdump settings required rebooting the system to reallocate memory accordingly. 
Base on above, I think this can make sense. So, I close this bug currently, please reopen it if any reasion or i make mistake about it.

Best Regards,
sluo

Note You need to log in before you can comment on or make changes to this bug.