Bug 1022533 - Fix invalid use of options["--??"] in fence agents
Fix invalid use of options["--??"] in fence agents
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: fence-agents (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 09:22 EDT by Marek Grac
Modified: 2014-06-18 03:24 EDT (History)
4 users (show)

See Also:
Fixed In Version: fence-agents-4.0.2-6.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:05:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Grac 2013-10-23 09:22:15 EDT
Some fence agents uses options with key "XXX" which can not be set properly. This bug was found in fence_rsb and fence_wti ; automatic method for checking should be introduced.
Comment 1 Marek Grac 2013-10-23 09:23:14 EDT
Patches together with automatic testing during build is in upstream
Comment 2 Marek Grac 2013-10-23 09:24:42 EDT
Affected agents are fence_drac5 [ignore comment #1] other fence agents are not supported.
Comment 7 Ludek Smid 2014-06-13 06:05:32 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.