Bug 102256 - ntpd -x flag no longer works to due droproot patch bug
ntpd -x flag no longer works to due droproot patch bug
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: ntp (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-12 19:52 EDT by Rob Mayoff
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-01 10:45:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Mayoff 2003-08-12 19:52:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

Description of problem:
Handling of the ntpd "-x" flag is broken.  Example:

# ntpd -x
ntpd: option requires argument -x
usage: ntpd [ -abdgmnqx ] [ -c config_file ] [ -e e_delay ]
                [ -f freq_file ] [ -k key_file ] [ -l log_file ]
                [ -p pid_file ] [ -r broad_delay ] [ -s statdir ]
                [ -t trust_key ] [ -v sys_var ] [ -V default_sysvar ]
                [ -T chroot_dir ] [ -U server_user ]
                [ -P fixed_process_priority ]

The problem is that the droproot patches modifies the ntp_options string to
indicate that "-x" requires an argument, which is incorrect.

Workaround: pass the "-x" flag twice in a row.  This will work with the broken
ntpd and will continue working when ntpd is fixed.  Example:

# ntpd -x -x
#


Version-Release number of selected component (if applicable):
ntp-4.1.2-0.rc1.2

How reproducible:
Always

Steps to Reproduce:
1.  Run "ntpd -x".
2.
3.
    

Actual Results:  ntpd claims that -x requires an argument.

Expected Results:  ntpd should run (and never step the clock).


Additional info:

To fix, change the droproot patch ("ntp-4.1.0b-rc1-droproot.patch") to not put a
":" after the "x" in ntp_options in cmd_args.c.
Comment 1 Harald Hoyer 2003-09-01 10:45:02 EDT
$ rpm -qpl ntp-4.1.2-0.rc1.2.src.rpm|fgrep droproot
ntp-4.1.1-droproot.patch

workx for me... was fixed in 9!! Look at your version!

Note You need to log in before you can comment on or make changes to this bug.