Bug 1022586 - Add support for Teiid artifacts in s-ramp
Add support for Teiid artifacts in s-ramp
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER8
: 6.0.0
Assigned To: Eric Wittmann
Stefan Bunciak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 11:10 EDT by Kurt T Stam
Modified: 2014-02-06 10:31 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Tested Teiid artifact #1 (2.78 KB, text/xml)
2014-01-06 09:28 EST, Stefan Bunciak
no flags Details
Tested Teiid artifact #2 (8.92 KB, application/zip)
2014-01-06 09:29 EST, Stefan Bunciak
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SRAMP-253 Major Closed Add support for Teiid artifacts in s-ramp 2014-02-13 09:33:24 EST

  None (edit)
Description Kurt T Stam 2013-10-23 11:10:41 EDT
Change Request:

Add support for Teiid artifacts as first-class supported artifacts in s-ramp. This should be done by implementing a deriver for the teiid XML file as well as an expander for Teiid archives (VDB).
Comment 2 Eric Wittmann 2013-10-24 10:01:26 EDT
This was implemented by Dan Florian and has been merged into both community and product.
Comment 3 Stefan Bunciak 2014-01-06 09:27:59 EST
Neither of the 2 Teiid artifacts were recognised correctly after import into s-ramp repository:

* Teiid archives (VDB) was recognized as 'Document' and no additional files were extracted/derived from it;
* Teiid XML file was imported as general XmlDocument.
Comment 4 Stefan Bunciak 2014-01-06 09:28:59 EST
Created attachment 846122 [details]
Tested Teiid artifact #1
Comment 5 Stefan Bunciak 2014-01-06 09:29:24 EST
Created attachment 846124 [details]
Tested Teiid artifact #2
Comment 6 Eric Wittmann 2014-01-22 09:12:02 EST
I just tested this with FSW6.CR1 and it worked.  I suspect this didn't work for you because you didn't specify the right Artifact Type when uploading the file(s).

When you import a *.vdb file in the UI you must specify the following value for Artifact Type in the Import Dialog:

    TeiidVdb

If you add a *-vdb.xml file in the UI then you need to use this value for Artifact Type:

    TeiidVdbManifest

We're currently working on adding documentation for this.
Comment 7 Jiri Pechanec 2014-01-24 07:24:19 EST
Verified in ER2 when explicit art types provided. Still it would be better to support implicit identification too.

Note You need to log in before you can comment on or make changes to this bug.