Bug 1022629 - PG_ComputerSystem carries CreationClassName="CIM_ComputerSystem"
PG_ComputerSystem carries CreationClassName="CIM_ComputerSystem"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tog-pegasus (Show other bugs)
7.0
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Vitezslav Crhonek
Robin Hack
:
Depends On:
Blocks: 1018674 1021931
  Show dependency treegraph
 
Reported: 2013-10-23 12:10 EDT by Tomáš Bžatek
Modified: 2015-03-03 18:07 EST (History)
3 users (show)

See Also:
Fixed In Version: tog-pegasus-2.12.1-9.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:42:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomáš Bžatek 2013-10-23 12:10:35 EDT
PG_ComputerSystem instances are having the CreationClassName property set to "CIM_ComputerSystem" instead of "PG_ComputerSystem". As long as this is one of the base classes used almost everywhere, it has quite large impact.

E.g. the bug 1021931 is partially caused by this issue.

Also upstream has acknowledged the problem and released a fix: http://bugzilla.openpegasus.org/show_bug.cgi?id=9795

This is a crucial piece that we would really like to have in the 7.0 release.

This is also needed for the proposed change in bug 1018674 to be actually usable.
Comment 1 Tomáš Bžatek 2013-10-23 12:11:53 EDT
FYI, testing on Fedora 20, the referenced patch fixes the issue.
Comment 4 Ludek Smid 2014-06-13 08:42:26 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.