Bug 1022640 - There should be an option to run oxenstored
There should be an option to run oxenstored
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
19
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Michael Young
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 13:04 EDT by Jeremy Fitzhardinge
Modified: 2013-11-10 21:34 EST (History)
4 users (show)

See Also:
Fixed In Version: xen-4.2.3-7.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 01:26:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Fitzhardinge 2013-10-23 13:04:54 EDT
Description of problem:
There should be an option ro run oxenstored instead of xenstored

Version-Release number of selected component (if applicable):
xen-runtime 4.2.3-4.fc19

How reproducible:
Always

Steps to Reproduce:
1. Boot under Xen
2.
3.

Actual results:
xenstored running

Expected results:
oxenstored running

Additional info:
Perhaps this could be done with alternatives?
Comment 1 Fedora Update System 2013-10-25 14:45:40 EDT
xen-4.2.3-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xen-4.2.3-5.fc18
Comment 2 Fedora Update System 2013-10-25 14:46:55 EDT
xen-4.2.3-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xen-4.2.3-5.fc19
Comment 3 Fedora Update System 2013-10-25 14:48:19 EDT
xen-4.3.0-9.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/xen-4.3.0-9.fc20
Comment 4 Michael Young 2013-10-25 15:09:24 EDT
I have added an oxenstored.service systemd file with a Conflicts rule to stop oxenstored and xenstored running together and give oxenstored priority if they are both enabled. It is enabled on install for F20 and later, but will need to be enabled manually on F18 and F19 as I don't want to change the behaviour of released versions of Fedora.
Comment 5 Fedora Update System 2013-10-26 14:49:56 EDT
Package xen-4.3.0-9.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xen-4.3.0-9.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20035/xen-4.3.0-9.fc20
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-10-29 16:07:57 EDT
xen-4.3.0-10.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/xen-4.3.0-10.fc20
Comment 7 Fedora Update System 2013-10-29 16:52:25 EDT
xen-4.2.3-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xen-4.2.3-6.fc19
Comment 8 Fedora Update System 2013-10-29 17:13:07 EDT
xen-4.2.3-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xen-4.2.3-6.fc18
Comment 9 Jeremy Fitzhardinge 2013-10-30 12:30:40 EDT
It looks like xen-runtime unconditionally enables xenstored even if oxenstored is enabled:

  Updating   : xen-runtime-4.2.3-6.fc19.x86_64                                            5/17 
ln -s '/usr/lib/systemd/system/xenstored.service' '/etc/systemd/system/multi-user.target.wants/xenstored.service'
Comment 10 Michael Young 2013-10-30 15:36:02 EDT
(In reply to Jeremy Fitzhardinge from comment #9)
> It looks like xen-runtime unconditionally enables xenstored even if
> oxenstored is enabled:
> 
>   Updating   : xen-runtime-4.2.3-6.fc19.x86_64                              
> 5/17 
> ln -s '/usr/lib/systemd/system/xenstored.service'
> '/etc/systemd/system/multi-user.target.wants/xenstored.service'

That is a hack for the transition from init.d scripts to systemd (so xenstored would run by default if you were updating from a xen version still using init.d). The hack has already been removed from the xen-4.3 installs in F20 and rawhide, and I may consider it for the F18 and F19 versions as well now there are no more supported Fedora xen versions using init.d.
In your case oxenstored should still win even if xenstored is enabled as well.
Comment 11 Fedora Update System 2013-11-01 19:25:38 EDT
xen-4.3.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/xen-4.3.1-1.fc20
Comment 12 Fedora Update System 2013-11-01 20:22:27 EDT
xen-4.2.3-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xen-4.2.3-7.fc19
Comment 13 Fedora Update System 2013-11-01 20:44:56 EDT
xen-4.2.3-7.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xen-4.2.3-7.fc18
Comment 14 Fedora Update System 2013-11-10 01:26:13 EST
xen-4.3.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2013-11-10 21:30:29 EST
xen-4.2.3-7.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2013-11-10 21:34:31 EST
xen-4.2.3-7.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.