Bug 1022657 - Upgrade quantum packages to neutron does not migrate config
Upgrade quantum packages to neutron does not migrate config
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-neutron (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Terry Wilson
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 13:54 EDT by Dan Smith
Modified: 2016-04-26 10:44 EDT (History)
4 users (show)

See Also:
Fixed In Version: openstack-neutron-2013.2-4.el6ost
Doc Type: Bug Fix
Doc Text:
Cause: The packaging didn't handle upgrading from grizzly/quantum to havana/neutron well. Consequence: Config files were not migrated, the quantum and neutron users had the same UID causing sudo/rootwrap issues, and neutron services that were enabled in grizzly would not be enabled after upgrading to havana. Fix: Add upgrade handling post upgrade Result: Upgrades happen more smoothly fron quantum to neutron. After doing a yum update, the user should only have to migrate the database and start the neutron services.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-07 13:22:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Smith 2013-10-23 13:54:01 EDT
Description of problem:

Installing neutron packages should migrate the quantum.conf file to neutron.conf. The upstream guidelines are that config files are to be compatible across releases, which means that not having the renamed package migrate the file is akin to a regular upgrade blowing away the previous config file and replacing it with a non-working default one.

Version-Release number of selected component (if applicable):

openstack-neutron-2013.2-1.el6.noarch

How reproducible:

Always.

Steps to Reproduce:
1. Install RDO-grizzly
2. Run packstack --allinone
3. Install RDO-havana
5. yum -y update

Actual results:

/etc/neutron/neutron.conf is the default config, which does not work out of the box.

Expected results:

/etc/quantum/quantum.conf should be copied to /etc/neutron/neutron.conf

Additional info:
Comment 1 Rushil Chugh 2013-11-12 17:34:34 EST
Hey Dan
I think some work has been done on this. Need info on this so that if the work has been done on it, we can close out this bug. The update I am referring to is http://jenkins.rhev.lab.eng.brq.redhat.com:8080/view/RDO-Current/job/packstack-rdo-grizzly-havana-upgrade/. Please let me know of the same at your earliest convenience.
Comment 2 Terry Wilson 2013-11-12 17:36:48 EST
re: doc text I just copied what was in https://bugzilla.redhat.com/show_bug.cgi?id=1022705 since I fixed this bug as a result of working on the other.
Comment 3 Dan Smith 2013-11-12 18:20:13 EST
The job you referenced is only testing a very simple upgrade scenario which does not include quantum/neutron. Thus, it is unrelated to this bug.

I think Terry is the one that should decide if this is moved along its way. I'm happy to test updated packages to confirm that they address the issue when they hit RDO.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.