Bug 1022707 - Changes (add/remove file) through SSH of NFS mounted directory (with nfsvers=3) are unseen through NFS
Changes (add/remove file) through SSH of NFS mounted directory (with nfsvers=...
Status: CLOSED DUPLICATE of bug 1018653
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.5
Unspecified Linux
unspecified Severity high
: rc
: ---
Assigned To: Steve Dickson
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 16:08 EDT by Sergey Gotliv
Modified: 2013-10-25 08:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-25 08:42:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergey Gotliv 2013-10-23 16:08:56 EDT
Description of problem:
I perform changes throung SSH in NFS-mounted directory and doesn't see these changes when coming to this directory from NFS client.


Version-Release number of selected component (if applicable):
nfs-utils-1.2.3-39.el6.x86_64

How reproducible:
I reproduced it on 3 different sets of RHEL 6.5 client/server machines
Few times I saw changes but in most case I didn't

Steps to Reproduce:
1.Create directory and export it to all 
2.Mount it with -t nfs -o nfsvers=3 
3.Start copying/removing files 

I added set of commands.

Actual results:
Changes are not reflected through NFS

Expected results:
I expect see changes


Additional info:

Server:

/etc/expots

/tmp/test    0.0.0.0/0.0.0.0(rw)


Client:

mount

10.35.64.153:/tmp/test on /mnt/mydir type nfs (rw,nfsvers=3,addr=10.35.64.153)

The set of commands on server:
vi /etc/exports
cd /tmp
mkdir test
chmod 777 test
exportfs -rv
service rpcbind status
service iptables stop
service nfs status
service nfs start
ll
cp kaka.cmd test     - this change I saw from NFS client
cp hsm.py test       - didn't see it from client
cp vdsm_log test     - didn't see it from client
rpm -qa nfs-utils

The set of commands on client:

cd /mnt/
ll
mkdir mydir
chmod 777 mydir
mount -t nfs 10.35.64.153:/tmp/test /mnt/mydir -o nfsver=3
Comment 3 Steve Dickson 2013-10-25 08:42:30 EDT

*** This bug has been marked as a duplicate of bug 1018653 ***

Note You need to log in before you can comment on or make changes to this bug.