Bug 1022708 - RHEL6 sssd upgrade restorecon workaround for /var/lib/sss/mc context
RHEL6 sssd upgrade restorecon workaround for /var/lib/sss/mc context
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Jakub Hrozek
Kaushik Banerjee
: ZStream
Depends On: 987456
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 16:09 EDT by Jan Kurik
Modified: 2013-11-20 06:05 EST (History)
13 users (show)

See Also:
Fixed In Version: sssd-1.9.2-82.11.el6_4
Doc Type: Bug Fix
Doc Text:
Previously, RPM did not reload its labels database in a single transaction. Consequently, when sssd was upgraded and pulled in a new selinux-policy in a single transaction, the new context added by the selinux-policy-targeted utility was not used for the files in the /var/lib/sss/mc/ directory. To fix this bug, sssd has been set to run restorecon in the %post scriptlet until RPM can properly handle it, and thus correct context is set.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-20 06:05:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2013-10-23 16:09:02 EDT
This bug has been copied from bug #987456 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 6 Clifton Coursey 2013-10-29 10:03:40 EDT
The customer has confirmed that the packages fixes his current issue.

From the case# 00969058:

<snip>
I can confirm that this package fixes the issue we're having.
<snip>

--cliff
Comment 7 Jakub Hrozek 2013-10-30 06:11:40 EDT
(In reply to Clifton Coursey from comment #6)
> The customer has confirmed that the packages fixes his current issue.
> 
> From the case# 00969058:
> 
> <snip>
> I can confirm that this package fixes the issue we're having.
> <snip>
> 
> --cliff

Great, thanks for testing! Any word on comment #5? Do they need a 6.5.z or can we give them access to the 6.5 bits?
Comment 8 Jakub Hrozek 2013-11-06 11:11:23 EST
(In reply to Jakub Hrozek from comment #7)
> (In reply to Clifton Coursey from comment #6)
> > The customer has confirmed that the packages fixes his current issue.
> > 
> > From the case# 00969058:
> > 
> > <snip>
> > I can confirm that this package fixes the issue we're having.
> > <snip>
> > 
> > --cliff
> 
> Great, thanks for testing! Any word on comment #5? Do they need a 6.5.z or
> can we give them access to the 6.5 bits?

ping; Any news?
Comment 14 errata-xmlrpc 2013-11-20 06:05:08 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1742.html

Note You need to log in before you can comment on or make changes to this bug.