Bug 1022740 - Add project maintainer dialog is of poor usability
Add project maintainer dialog is of poor usability
Status: CLOSED WORKSFORME
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: zanata-dev-internal
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 18:21 EDT by Damian Jansen
Modified: 2014-07-06 23:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-06 23:18:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damian Jansen 2013-10-23 18:21:04 EDT
Description of problem:
The dialog that allows a project maintainer to add another maintainer is poorly defined and implemented. It allows the user to accidentally add other users and doesn't behave intuitively in filling out the visible user details.

Version-Release number of selected component (if applicable):
3.x

How reproducible:
Easy always

Steps to Reproduce:
1. Log in as an admin or maintainer
2. Go to a project
3. Click Manage Maintainers
4. Click Add
5. Enter the name of an existing user, but don't select them
   - Note that they show in a list, but no other details are filled in
6. Press Enter
   - Note that nothing appears to happen
7. Press Enter again - user assuming enter will show them the user details

Actual results:
Nothing appears to happen in the foreground, but the user is added as a maintainer in the background

Expected results:
The foreground dialog should be filled in. Only on clicking Add should a user be added.

Additional info:
Comment 1 Damian Jansen 2013-11-03 22:35:38 EST
Also, attempting to add a user that is already a maintainer provides no feedback to the user.
Comment 2 Alex Eng 2014-06-17 23:06:38 EDT
Is this still an issue with user interface has been changed since 3.3.0?
Comment 3 Damian Jansen 2014-07-06 23:18:52 EDT
Negative. Closing.

Note You need to log in before you can comment on or make changes to this bug.