Bug 1022746 - texlive update falls apart on unsatisified dependencies
texlive update falls apart on unsatisified dependencies
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: texlive (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 19:04 EDT by Michal Jaegermann
Modified: 2013-11-10 03:03 EST (History)
3 users (show)

See Also:
Fixed In Version: texlive-2013-3.20131021_r31961.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 03:03:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum output from a failed update attempt (438.13 KB, text/plain)
2013-10-23 19:04 EDT, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2013-10-23 19:04:43 EDT
Created attachment 815589 [details]
yum output from a failed update attempt

Description of problem:

An attempt to run texlive updates for the current rawhide installation fails.  In a case of my installation this is 1209 packages which have to be skipped.  It is not easy to make a head or tail from all of this due to a volume but AFAICT the issue is that a number of packages needs 
texlive-kpathsea-lib-2013-2.20131019_r31948.fc21 while numerous already installed require 2013-0.5.20130608_r30832.fc20 version.  In case of x86_64 installation yum tries to get missing dependencies by adding texlive-kpathsea-lib-2013-2.20131019_r31948.fc21.i686 to the mess and this does not help, obviously, the tiniest bit.

Version-Release number of selected component (if applicable):
texlive-2013-2.20131019_r31948.fc21

Additional info:
Packages in question are already a few days old so this does not look like messy mirrors; but I can be mistaken.

A yum output from a failed update attempt is attached.  In order to avoid mudding waters a number of Perl packages this updates brings as dependencies is already separately installed.
Comment 1 Michal Jaegermann 2013-10-29 16:19:15 EDT
texlive-2013-3.20131021_r31961.fc21 and other packages from that bunch do not suffer from the problem anymore.
Comment 2 Fedora Update System 2013-10-31 14:23:36 EDT
texlive-2013-3.20131021_r31961.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-19153/texlive-2013-3.20131021_r31961.fc20
Comment 3 Michal Jaegermann 2013-10-31 15:06:45 EDT
As a note on a margin.  I thought that the idea behind splitting a TeX installation into thousands of packages was to make possible separate component updates. Currently interdependencies are so tight that such things are doable only to a very limited extent.  Does this really have to be that way?
Comment 4 Fedora Update System 2013-11-01 16:26:52 EDT
Package texlive-2013-3.20131021_r31961.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing texlive-2013-3.20131021_r31961.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19153/texlive-2013-3.20131021_r31961.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-11-10 03:03:19 EST
texlive-2013-3.20131021_r31961.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.