Bug 102276 - /bin/ls dumps error messages if there is no acl information available
/bin/ls dumps error messages if there is no acl information available
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
:
: 102398 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-13 06:28 EDT by Thomas Woerner
Modified: 2007-11-30 17:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-26 20:44:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Woerner 2003-08-13 06:28:38 EDT
Description of problem:
/bin/ls dumps error messages if there is no acl information available.

Version-Release number of selected component (if applicable):
coreutils-4.5.3-26

How reproducible:
always

Steps to Reproduce:
1. mount nfs directory with no acl information
   (nfs server is a 7.3 with kernel 2.4.20-8)
2. ls -l
3.
    
Actual results:

dist/3.0E $ ls -l
ls: autorun: Input/output error
ls: beta_eula.txt: Input/output error
ls: dosutils: Input/output error
ls: GPL: Input/output error
ls: images: Input/output error
ls: isolinux: Input/output error
ls: RedHat: Input/output error
ls: RPM-GPG-KEY: Input/output error
ls: RPM-GPG-KEY-beta: Input/output error
ls: SRPMS: Input/output error
total 60
-rwxr-xr-x    1 twoerner twoerner      248 Jul 20 23:06 autorun
-rw-r--r--    1 twoerner twoerner     4084 Jul 20 22:39 beta_eula.txt
drwxr-xr-x    7 twoerner twoerner     4096 Aug 13 00:29 dosutils
-rw-r--r--    1 twoerner twoerner    18385 Aug 13 00:06 GPL
drwxr-xr-x    3 twoerner twoerner     4096 Aug 13 01:02 images
drwxr-xr-x    2 twoerner twoerner     4096 Aug 13 00:29 isolinux
drwxr-xr-x    4 twoerner twoerner     4096 Aug 13 00:04 RedHat
-rw-r--r--    1 twoerner twoerner     1910 Aug 13 00:06 RPM-GPG-KEY
-rw-r--r--    1 twoerner twoerner     1706 Aug 13 00:06 RPM-GPG-KEY-beta
drwxr-xr-x    2 twoerner twoerner     8192 Aug 13 12:19 SRPMS


Expected results:

dist/3.0E $ ls -l
total 60
-rwxr-xr-x    1 twoerner twoerner      248 Jul 20 23:06 autorun
-rw-r--r--    1 twoerner twoerner     4084 Jul 20 22:39 beta_eula.txt
drwxr-xr-x    7 twoerner twoerner     4096 Aug 13 00:29 dosutils
-rw-r--r--    1 twoerner twoerner    18385 Aug 13 00:06 GPL
drwxr-xr-x    3 twoerner twoerner     4096 Aug 13 01:02 images
drwxr-xr-x    2 twoerner twoerner     4096 Aug 13 00:29 isolinux
drwxr-xr-x    4 twoerner twoerner     4096 Aug 13 00:04 RedHat
-rw-r--r--    1 twoerner twoerner     1910 Aug 13 00:06 RPM-GPG-KEY
-rw-r--r--    1 twoerner twoerner     1706 Aug 13 00:06 RPM-GPG-KEY-beta
drwxr-xr-x    2 twoerner twoerner     8192 Aug 13 12:19 SRPMS


Additional info:

strace output:
...
lstat64("autorun", {st_mode=S_IFREG|0755, st_size=248, ...}) = 0
getxattr("autorun", "system.posix_acl_access", (nil), 0) = -1 EIO (Input/output 
error)
write(2, "ls: ", 4ls: )                     = 4
write(2, "autorun", 7autorun)                  = 7
write(2, ": Input/output error", 20: Input/output error)    = 20
write(2, "\n", 1
)                       = 1
...
Comment 1 Tim Waugh 2003-08-13 11:58:35 EDT
Reproduced with a Cambridge server using no_acl in /etc/exports.

On current Cambridge trees the strace looks different: getxattr correctly
returns EOPNOTSUPP for this case.

I suspect the kernel to be at fault here.
Comment 2 Bill Nottingham 2003-08-13 23:00:34 EDT
*** Bug 102338 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2003-08-14 16:42:11 EDT
*** Bug 102398 has been marked as a duplicate of this bug. ***
Comment 4 Steve Dickson 2003-08-15 15:57:33 EDT
The no_acl options is an export option for NFS servers
and is only support in taroon kernels. So I'm a bit
confused on how a 7.3 server comes into play in this 
picture.

Could you please post the following info:
On the server
cat /proc/fs/nfs/exports or /etc/exports

On the client
cat /proc/mounts or the exact mount command




Comment 5 Thomas Woerner 2003-08-16 06:53:55 EDT
NFS server: RH 7.3 with latest updates
======================================

/etc/exports:
/share                  192.168.254.0/255.255.255.0(rw,no_root_squash,nohide)

/proc/fs/nfs/exports:
/share  neo.tm.hn.org(rw,no_root_squash,async,wdelay,nohide) # 192.168.254.7

NFS client: Taroon with latest updates
======================================

/proc/mounts:
gate:/share /share nfs rw,v3,rsize=8192,wsize=8192,hard,udp,lock,addr=gate 0 0

/etc/fstab:
gate:/share             /share                  nfs     defaults        0 0
Comment 6 Steve Dickson 2003-08-19 13:48:52 EDT
using a 2.4.21-1.1931.2.391.entsmp taroon client
and a 2.4.20-19.7 7.3 server I'm unable to reproduce
this problem...

Would it be possible to post a ethereal trace of
when this problem occurs?
Comment 7 Steve Dickson 2003-08-19 17:29:51 EDT
what version of coreutils are you using
rpm -qf /bin/ls will show it...

Comment 8 Thomas Woerner 2003-08-22 15:11:25 EDT
Version-Release number of selected component (if applicable):
coreutils-4.5.3-26
Comment 9 Ed Griffin 2003-08-22 15:24:06 EDT
I was able to reproduce consistantly using both other RedHat systems (mostly 7.3
and 8.0) as the NFS servers as well as trying to mount a Network Appliance File
Server using NFS v3 over TCP.  This did not happen when mounting a remote
Solaris 8 server using NFS v3 over TCP.  I have worked around the problem
temporarily by forcing my Taroon WS client to mount only using NFS v2.

Note You need to log in before you can comment on or make changes to this bug.