Bug 1022843 - qmp show unfriendly error message when memsave save file to read only file system
qmp show unfriendly error message when memsave save file to read only file sy...
Status: CLOSED DUPLICATE of bug 907743
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Laszlo Ersek
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 03:09 EDT by FuXiangChun
Modified: 2013-12-17 12:49 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-17 12:49:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description FuXiangChun 2013-10-24 03:09:35 EDT
Description of problem:
save memsave file to read only nfs file system via qmp. qmp show error:
{"error": {"class": "GenericError", "desc": "Could not open 'filename'"}}

Tested other qmp command. e.g screendump.  It show a correctly error message.
{"error": {"class": "GenericError", "desc": "failed to open file 'screen-file': Read-only file system"}}

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-1.5.3-10.el7.x86_64
3.10.0-35.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Boot guest with qmp
/usr/libexec/qemu-kvm -M q35 -cpu SandyBridge -enable-kvm -m 10G -smp 8,sockets=2,cores=4,threads=1,maxcpus=160 -usb -device usb-tablet,id=input0 -name sluo -uuid ec15da0a-e8a7-42f4-905a-78fed78fd8fd -rtc base=localtime,clock=host,driftfix=slew -device ahci,id=ahci0,addr=0x04 -drive file=/home/win8.1-32.qcow2,if=none,id=drive-sata-disk-0-0,format=qcow2 -device ide-drive,bus=ahci0.0,unit=0,drive=drive-sata-disk-0-0,id=sata-disk-0-0 -netdev tap,script=/etc/qemu-ifup,id=netdev0 -device virtio-net-pci,netdev=netdev0,id=virtio-net-pci0,mac=e4:1f:13:eb:40:24,addr=0x5 -device virtio-balloon-pci,id=b1 -vnc :1 -monitor stdio  -boot menu=on -spice port=5931,disable-ticketing -vga qxl -global qxl-vga.revision=3 -qmp tcp:0:4444,server,nowait

2.save memsave file to read only nfs file system via qmp
{"execute":"memsave","arguments":{"val":1,"size":9999999,"filename":"mem-dump"}}

3.

Actual results:
{"error": {"class": "GenericError", "desc": "Could not open 'mem-dump'"}}

Expected results:
{"error": {"class": "GenericError", "desc": "failed to open file 'mem-dump': Read-only file system"}}

Additional info:
Comment 2 Laszlo Ersek 2013-12-17 12:49:50 EST
This bug is a duplicate of bug 907743, which has been fixed with RHEL-7 commit

commit 36268b43efcc3d639e973a4a47cb32d38e92bc93
Author: Laszlo Ersek <lersek@redhat.com>
Date:   Thu Oct 31 16:29:27 2013 +0100

    cpus: use error_setg_file_open()

in build "qemu-kvm-1.5.3-14.el7". (This BZ was reported against "qemu-kvm-rhev-1.5.3-10.el7".)

I'm closing it now as a dupe, but if you want to retest it too, please feel free to reopen it and move it immediately to ON_QA. Thanks.

*** This bug has been marked as a duplicate of bug 907743 ***

Note You need to log in before you can comment on or make changes to this bug.