Bug 1022905 - quota build: reset command fails
quota build: reset command fails
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
pre-release
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anuradha
: ZStream
Depends On: 1000903
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 05:08 EDT by Anuradha
Modified: 2016-09-19 22:00 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1000903
Environment:
Last Closed: 2014-04-17 07:49:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-10-24 05:37:46 EDT
REVIEW: http://review.gluster.org/6135 (glusterd : Improved quota volume reset command) posted (#1) for review on master by Anuradha Talur (atalur@redhat.com)
Comment 2 Anand Avati 2013-10-28 08:26:40 EDT
REVIEW: http://review.gluster.org/6135 (glusterd : Improved quota volume reset command) posted (#2) for review on master by Anuradha Talur (atalur@redhat.com)
Comment 3 Anand Avati 2013-10-28 14:39:27 EDT
COMMIT: http://review.gluster.org/6135 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit fc86b3a22ab0519652f74ef8a75cf1cbfa290fb8
Author: Anuradha <atalur@redhat.com>
Date:   Thu Oct 24 15:03:48 2013 +0530

    glusterd : Improved quota volume reset command
    
    Quota volume reset command without "force"
    option fixed, doesn't fail anymore. It resets
    unprotected fields and not the protected ones.
    
    Also, an appropriate message is provided to the user
    for the following cases :
    1. only unprotected fields are reset, "force" option
    should be used to reset protected fields.
    2. Both protected and unprotected fields are reset.
    3. No field was reset, "force" option required.
    
    Test case for the same also added.
    
    Change-Id: I24e8f1be87b79ccd81bf6f933e00608b861c7a16
    BUG: 1022905
    Signed-off-by: Anuradha <atalur@redhat.com>
    Reviewed-on: http://review.gluster.org/6135
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 4 Niels de Vos 2014-04-17 07:49:59 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.