Bug 1022927 - Please enhance /usr/share/spamassassin/sa-update.cron with RHEL 6 script
Please enhance /usr/share/spamassassin/sa-update.cron with RHEL 6 script
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: spamassassin (Show other bugs)
5.10
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Petr Lautrbach
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 05:36 EDT by Robert Scheck
Modified: 2014-07-15 09:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:06:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2013-10-24 05:36:39 EDT
Description of problem:
Package spamassassin-3.3.1-2.el5 from 2011 contains long and extended script
/usr/share/spamassassin/sa-update.cron, which takes care about SpamAssassin
channels, imports GPG keys as needed and finally also restarts services such
as SpamAssassin (spamd), Amavisd-New and MIMEDefang if needed.

Compared to that, package spamassassin-3.3.1-4.el5 is a simple stupid script
that only does sa-update(1) (after sleeping for random time) and restarts a
possible SpamAssassin server process (spamd) - no handling of Amavisd-New or
MIMEDefang anymore.

Version-Release number of selected component (if applicable):
spamassassin-3.3.1-2.el5
spamassassin-3.3.1-4.el5

How reproducible:
Everytime, just update from older SpamAssassin to latest in RHEL 5.

Actual results:
SpamAssassin 3.3.1-4.el5 cripples /usr/share/spamassassin/sa-update.cron.

Expected results:
Non-crippled /usr/share/spamassassin/sa-update.cron like 3.3.1-2.el5 again.

Additional info:
As even Fedora Rawhide ships the more extended script (see Fedora GIT), I do
not see any reason to deal with that (unintended?) new change.
Comment 1 Robert Scheck 2013-10-24 05:40:46 EDT
Cross-filed ticket 00970061 in the Red Hat customer portal.
Comment 2 Robert Scheck 2013-10-24 05:41:57 EDT
Sorry, I have to correct myself here: I mixed up RHEL 5 and 6. Actually even
spamassassin-3.3.1-2.el5 ships that small and crippled version of the cronjob.
Instead I would like to raise the request to ship the more enhanced version of
/usr/share/spamassassin/sa-update.cron of RHEL 6 also in RHEL 5 hereby.
Comment 4 RHEL Product and Program Management 2014-03-07 07:17:12 EST
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in the  last planned RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX. To request that Red Hat re-consider this request, please re-open the bugzilla via  appropriate support channels and provide additional business and/or technical details about its importance to you.
Comment 5 RHEL Product and Program Management 2014-06-02 09:06:28 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.