Bug 1022939 - xmvn: javaRequires not generated in fragments
xmvn: javaRequires not generated in fragments
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xmvn (Show other bugs)
rawhide
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
: Upstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 06:06 EDT by Stanislav Ochotnicky
Modified: 2013-11-07 02:04 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.3.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-07 02:04:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stanislav Ochotnicky 2013-10-24 06:06:07 EDT
Description of problem:
xmvn does not generate either javaRequires or javaDevelRequires inside fragment files for several packages (found during review bug 1022908). Thus javapackages generators don't create requires on JRE/JVM. This could eventually cause problems if enough packages miss basic requires

Version-Release number of selected component (if applicable):
xmvn-1.1.0-2.fc21
Comment 1 Mikolaj Izdebski 2013-10-24 06:44:24 EDT
The problem is that now XMvn MOJO writes simplified effective model with unneeded parts removed.  Maven Compiler Plugin invocation is removed too, which means that information about Java version is lost.
Comment 2 Mikolaj Izdebski 2013-11-01 05:21:35 EDT
Fixed upstream in commit 9cd1957
Comment 3 Mikolaj Izdebski 2013-11-05 11:31:01 EST
Fixed in xmvn-1.2.0-5
Comment 4 Mikolaj Izdebski 2013-11-07 02:04:39 EST
I believe that this bug is fixed in xmvn-1.3.0-1,
which is available in Fedora Rawhide, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=476472

Note You need to log in before you can comment on or make changes to this bug.