Bug 1022953 - rhevm is19 fails with 'JBAS014674: Failed to load module org.jboss.as.jaxrs'
rhevm is19 fails with 'JBAS014674: Failed to load module org.jboss.as.jaxrs'
Status: NEW
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: RPMs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: EAP 6.3.0
Assigned To: Fernando Nasser
Katerina Novotna
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 06:50 EDT by Yedidyah Bar David
Modified: 2016-12-05 09:46 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhevm boot.log (6.65 KB, text/x-log)
2013-10-24 06:50 EDT, Yedidyah Bar David
no flags Details
rpm -qa (30.18 KB, text/plain)
2013-10-24 06:51 EDT, Yedidyah Bar David
no flags Details
rpm -qa after update (30.76 KB, text/plain)
2013-10-24 08:52 EDT, Yedidyah Bar David
no flags Details

  None (edit)
Description Yedidyah Bar David 2013-10-24 06:50:28 EDT
Created attachment 815726 [details]
rhevm boot.log

Description of problem:

I had a not very up-to-date machine, installed rhevm is19, engine-setup finished successfully, engine died with the message in the subject. Full boot.log and output of 'rpm -qa' are attached.

'yum update' solved this. It's probably a missing, or not accurate enough, dependency between various components of jboss or related stuff.
Comment 1 Yedidyah Bar David 2013-10-24 06:51:14 EDT
Created attachment 815727 [details]
rpm -qa
Comment 2 Fernando Nasser 2013-10-24 08:42:49 EDT
What did "yum update" install?  That is the most important bit of information as it should contain the missing bit.
Comment 3 Yedidyah Bar David 2013-10-24 08:52:25 EDT
Created attachment 815763 [details]
rpm -qa after update
Comment 4 Fernando Nasser 2013-10-25 17:46:12 EDT
Hi Yedidyah,

Our supported installation instructions are in the Install guide.  They are indeed based on a yum update of a sort.  That is the only one tested and supported.

When I looked at the before and after rpm -qa that you posted, I've also noticed that other things in your OS, including the Java itself (and the kernel and so on) were not up-to-date.  The Install Guide also requires that the OS be brought to up-to-date state before installing (or upgrading).

For using these test yum repos RCM provides, there are special instructions described in:

https://docspace.corp.redhat.com/docs/DOC-99526

Please make sure you follow that.

If you guys follow the installation instructions (as you have been done so far) all will go well.

This said, we have some changes planned for 6.3 that may be able to make what you did work, so please leave this open for reference.

Best regards,
Fernando

Note You need to log in before you can comment on or make changes to this bug.