Bug 1022960 - Throw "TypeError("The type (<type 'bool'>) of OVIRT_PUPPET_ENABLED" error when disabling puppet
Throw "TypeError("The type (<type 'bool'>) of OVIRT_PUPPET_ENABLED" error whe...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: 3.4.1
Assigned To: Ryan Barry
bugs@ovirt.org
node
:
Depends On:
Blocks: 1023642
  Show dependency treegraph
 
Reported: 2013-10-24 07:15 EDT by haiyang,dong
Modified: 2014-04-30 07:04 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1023642 (view as bug list)
Environment:
Last Closed: 2014-04-30 07:04:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached Screenshot (15.08 KB, image/png)
2013-10-24 07:15 EDT, haiyang,dong
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20487 None None None Never

  None (edit)
Description haiyang,dong 2013-10-24 07:15:11 EDT
Created attachment 815733 [details]
attached Screenshot

Description of problem:
Using edit-node install ovirt-node-plugin-puppet into ovirt-node-iso and clean install this
iso .Login it and enter into puppet page, configure 
Puppet Server:master.example.com
Puppet Certificate Name: agent2.example.com
after clicking "Save" button to apply this configuration. check that it will configure puppet success.

But when disabling puppet via unchecked "Enable Puppet []", it will throw execption
about "TypeError("The type (<type 'bool'>) of OVIRT_PUPPET_ENABLED" error info.(Seen execption when disable puppet.png )

Version-Release number of selected component (if applicable):
ovirt-node-iso-3.1.0-0.999.1132.el6.iso
ovirt-node-plugin-puppet-3.1.0-0.999.20131024005255gitc1886e2.el6.noarch.rpm

How reproducible:
100%

Steps to Reproduce:

Actual results:


Expected results:
Comment 1 Sandro Bonazzola 2014-03-04 04:22:11 EST
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.

Note You need to log in before you can comment on or make changes to this bug.