Bug 1022995 - quota: moving files between directories does not update the size field properly
quota: moving files between directories does not update the size field properly
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
pre-release
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Raghavendra G
:
Depends On: 871015
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 08:24 EDT by Raghavendra G
Modified: 2014-04-17 07:50 EDT (History)
11 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 871015
Environment:
Last Closed: 2014-04-17 07:50:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-10-24 08:30:46 EDT
REVIEW: http://review.gluster.org/6138 (features/marker: don't honour GLUSTERFS_INTERNAL_FOP_KEY) posted (#1) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 2 Anand Avati 2013-10-28 01:57:06 EDT
REVIEW: http://review.gluster.org/6152 (core: add dht_is_linkfile helper procedure.) posted (#1) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 3 Anand Avati 2013-10-28 01:57:15 EDT
REVIEW: http://review.gluster.org/6153 (features/marker-quota: exclude dht-linkfiles from being accounted.) posted (#1) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 4 Anand Avati 2013-10-28 01:57:23 EDT
REVIEW: http://review.gluster.org/6154 (core: introduce internal fop types) posted (#1) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 5 Anand Avati 2013-10-28 06:21:30 EDT
REVIEW: http://review.gluster.org/6153 (features/marker-quota: exclude dht-linkfiles from being accounted.) posted (#2) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 6 Anand Avati 2013-10-28 06:21:39 EDT
REVIEW: http://review.gluster.org/6152 (core: add dht_is_linkfile helper procedure.) posted (#2) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 7 Anand Avati 2013-10-28 06:21:57 EDT
REVIEW: http://review.gluster.org/6154 (core: introduce internal fop types) posted (#2) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 8 Anand Avati 2013-10-28 09:49:42 EDT
REVIEW: http://review.gluster.org/6138 (features/marker: don't honour GLUSTERFS_INTERNAL_FOP_KEY) posted (#2) for review on master by Krishnan Parthasarathi (kparthas@redhat.com)
Comment 9 Anand Avati 2013-10-28 12:38:30 EDT
REVIEW: http://review.gluster.org/6138 (features/marker: don't honour GLUSTERFS_INTERNAL_FOP_KEY) posted (#3) for review on master by Krishnan Parthasarathi (kparthas@redhat.com)
Comment 10 Anand Avati 2013-10-31 02:02:45 EDT
REVIEW: http://review.gluster.org/6153 (features/marker-quota: exclude dht-linkfiles from being accounted.) posted (#3) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 11 Anand Avati 2013-10-31 02:02:56 EDT
REVIEW: http://review.gluster.org/6152 (core: add dht_is_linkfile helper procedure.) posted (#3) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 12 Anand Avati 2013-10-31 02:03:35 EDT
REVIEW: http://review.gluster.org/6203 (cluster/dht: instruct marker whenever it shouldn't do accounting) posted (#1) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 13 Anand Avati 2013-10-31 02:03:44 EDT
REVIEW: http://review.gluster.org/6204 (features/marker: remove dead code in unlink codepath.) posted (#1) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 14 Anand Avati 2013-11-04 06:13:00 EST
REVIEW: http://review.gluster.org/6153 (features/marker-quota: exclude dht-linkfiles from being accounted.) posted (#4) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 15 Anand Avati 2013-11-04 06:13:11 EST
REVIEW: http://review.gluster.org/6203 (cluster/dht: instruct marker whenever it shouldn't do accounting) posted (#2) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 16 Anand Avati 2013-11-04 06:13:19 EST
REVIEW: http://review.gluster.org/6152 (core: add dht_is_linkfile helper procedure.) posted (#4) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 17 Anand Avati 2013-11-04 06:13:53 EST
REVIEW: http://review.gluster.org/6204 (features/marker: remove dead code in unlink codepath.) posted (#2) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 18 Anand Avati 2013-11-11 08:58:01 EST
REVIEW: http://review.gluster.org/6153 (features/marker-quota: exclude dht-linkfiles from being accounted.) posted (#5) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 19 Anand Avati 2013-11-11 08:58:10 EST
REVIEW: http://review.gluster.org/6203 (cluster/dht: instruct marker whenever it shouldn't do accounting) posted (#3) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 20 Anand Avati 2013-11-11 08:58:23 EST
REVIEW: http://review.gluster.org/6152 (core: add dht_is_linkfile helper procedure.) posted (#5) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 21 Anand Avati 2013-11-11 08:59:02 EST
REVIEW: http://review.gluster.org/6204 (features/marker: remove dead code in unlink codepath.) posted (#3) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 22 Anand Avati 2013-11-11 11:32:07 EST
REVIEW: http://review.gluster.org/6153 (features/marker-quota: exclude dht-linkfiles from being accounted.) posted (#6) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 23 Anand Avati 2013-11-11 11:32:19 EST
REVIEW: http://review.gluster.org/6203 (cluster/dht: instruct marker whenever it shouldn't do accounting) posted (#4) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 24 Anand Avati 2013-11-11 11:32:27 EST
REVIEW: http://review.gluster.org/6152 (core: add dht_is_linkfile helper procedure.) posted (#6) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 25 Anand Avati 2013-11-11 13:07:21 EST
REVIEW: http://review.gluster.org/6153 (features/marker-quota: exclude dht-linkfiles from being accounted.) posted (#7) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 26 Anand Avati 2013-11-11 13:07:30 EST
REVIEW: http://review.gluster.org/6203 (cluster/dht: instruct marker whenever it shouldn't do accounting) posted (#5) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 27 Anand Avati 2013-11-11 13:07:38 EST
REVIEW: http://review.gluster.org/6152 (core: add dht_is_linkfile helper procedure.) posted (#7) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 28 Anand Avati 2013-11-12 10:12:35 EST
REVIEW: http://review.gluster.org/6153 (features/marker-quota: exclude dht-linkfiles from being accounted.) posted (#8) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 29 Anand Avati 2013-11-12 10:12:45 EST
REVIEW: http://review.gluster.org/6203 (cluster/dht: instruct marker whenever it shouldn't do accounting) posted (#6) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 30 Anand Avati 2013-11-12 10:12:55 EST
REVIEW: http://review.gluster.org/6152 (core: add dht_is_linkfile helper procedure.) posted (#8) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 31 Anand Avati 2013-11-12 10:13:35 EST
REVIEW: http://review.gluster.org/6253 (tests: add EXPECT_NOT macro) posted (#1) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 32 Anand Avati 2013-11-13 06:17:13 EST
REVIEW: http://review.gluster.org/6153 (features/marker-quota: exclude dht-linkfiles from being accounted.) posted (#9) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 33 Anand Avati 2013-11-13 06:17:23 EST
REVIEW: http://review.gluster.org/6203 (cluster/dht: instruct marker whenever it shouldn't do accounting) posted (#7) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 34 Anand Avati 2013-11-13 06:17:31 EST
REVIEW: http://review.gluster.org/6152 (core: add dht_is_linkfile helper procedure.) posted (#9) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 35 Anand Avati 2013-11-13 06:17:40 EST
REVIEW: http://review.gluster.org/6253 (tests: add EXPECT_NOT macro) posted (#2) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 36 Anand Avati 2013-11-14 07:03:40 EST
REVIEW: http://review.gluster.org/6153 (features/marker-quota: exclude dht-linkfiles from being accounted.) posted (#10) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 37 Anand Avati 2013-11-14 07:03:49 EST
REVIEW: http://review.gluster.org/6203 (cluster/dht: instruct marker whenever it shouldn't do accounting) posted (#8) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 38 Anand Avati 2013-11-14 07:03:59 EST
REVIEW: http://review.gluster.org/6152 (core: add dht_is_linkfile helper procedure.) posted (#10) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 39 Anand Avati 2013-11-14 07:04:08 EST
REVIEW: http://review.gluster.org/6253 (tests: add EXPECT_NOT macro) posted (#3) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 40 Anand Avati 2013-11-14 07:44:23 EST
REVIEW: http://review.gluster.org/6153 (features/marker-quota: exclude dht-linkfiles from being accounted.) posted (#11) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 41 Anand Avati 2013-11-14 07:44:31 EST
REVIEW: http://review.gluster.org/6203 (cluster/dht: instruct marker whenever it shouldn't do accounting) posted (#9) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 42 Anand Avati 2013-11-14 07:44:43 EST
REVIEW: http://review.gluster.org/6152 (core: add dht_is_linkfile helper procedure.) posted (#11) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 43 Anand Avati 2013-11-14 07:44:52 EST
REVIEW: http://review.gluster.org/6253 (tests: add EXPECT_NOT macro) posted (#4) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 44 Anand Avati 2013-11-26 01:05:36 EST
REVIEW: http://review.gluster.org/6153 (features/marker-quota: exclude dht-linkfiles from being accounted.) posted (#28) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 45 Anand Avati 2013-11-26 01:05:47 EST
REVIEW: http://review.gluster.org/6203 (cluster/dht: instruct marker whenever it shouldn't do accounting) posted (#26) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 46 Anand Avati 2013-11-26 01:05:56 EST
REVIEW: http://review.gluster.org/6152 (core: add dht_is_linkfile helper procedure.) posted (#28) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 47 Anand Avati 2013-11-26 05:45:23 EST
REVIEW: http://review.gluster.org/6153 (features/marker-quota: exclude dht-linkfiles from being accounted.) posted (#29) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 48 Anand Avati 2013-11-26 05:45:37 EST
REVIEW: http://review.gluster.org/6203 (cluster/dht: instruct marker whenever it shouldn't do accounting) posted (#27) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 49 Anand Avati 2013-11-26 05:45:53 EST
REVIEW: http://review.gluster.org/6152 (core: add dht_is_linkfile helper procedure.) posted (#29) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 50 Anand Avati 2013-11-26 06:40:37 EST
REVIEW: http://review.gluster.org/6153 (features/marker-quota: exclude dht-linkfiles from being accounted.) posted (#30) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 51 Anand Avati 2013-11-26 06:40:47 EST
REVIEW: http://review.gluster.org/6203 (cluster/dht: instruct marker whenever it shouldn't do accounting) posted (#28) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 52 Anand Avati 2013-11-26 06:40:57 EST
REVIEW: http://review.gluster.org/6152 (core: add dht_is_linkfile helper procedure.) posted (#30) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 53 Anand Avati 2013-11-26 07:28:34 EST
REVIEW: http://review.gluster.org/6153 (features/marker-quota: exclude dht-linkfiles from being accounted.) posted (#31) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 54 Anand Avati 2013-11-26 07:28:43 EST
REVIEW: http://review.gluster.org/6203 (cluster/dht: instruct marker whenever it shouldn't do accounting) posted (#29) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 55 Anand Avati 2013-11-26 07:28:54 EST
REVIEW: http://review.gluster.org/6152 (core: add dht_is_linkfile helper procedure.) posted (#31) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 56 Anand Avati 2013-11-26 13:26:52 EST
COMMIT: http://review.gluster.org/6152 committed in master by Anand Avati (avati@redhat.com) 
------
commit 1a2f51144fcbd920a6f3769d6b2f3ceeefdc220d
Author: Raghavendra G <rgowdapp@redhat.com>
Date:   Thu Nov 14 17:10:09 2013 +0530

    core: add dht_is_linkfile helper procedure.
    
    components other than distribute (like marker to exclude linkfiles
    from being accounted) also need awareness of what constitutes a
    linkfile. Hence its good to separate out this functionality into
    core.
    
    Change-Id: Ib944eeacc991bb1de464c9e73ee409fc7a689ff1
    BUG: 1022995
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: http://review.gluster.org/6152
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 57 Anand Avati 2013-11-26 13:27:14 EST
COMMIT: http://review.gluster.org/6153 committed in master by Anand Avati (avati@redhat.com) 
------
commit 75f66a98dad3882aff4a68cf0648016101f0a416
Author: Raghavendra G <rgowdapp@redhat.com>
Date:   Mon Oct 28 10:32:52 2013 +0530

    features/marker-quota: exclude dht-linkfiles from being accounted.
    
    Change-Id: I3239f5e8477664dcc04434e4d455ae447493a7ac
    BUG: 1022995
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: http://review.gluster.org/6153
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 58 Anand Avati 2013-11-26 13:27:32 EST
COMMIT: http://review.gluster.org/6203 committed in master by Anand Avati (avati@redhat.com) 
------
commit 33e0df30cbffbfbda5197704d0f788c83cd7ed78
Author: Raghavendra G <rgowdapp@redhat.com>
Date:   Thu Oct 31 06:35:47 2013 +0530

    cluster/dht: instruct marker whenever it shouldn't do accounting
    
    This is needed for two reasons:
    
    * since dht-linkfiles are internal, they shouldn't be accounted.
    * hardlink handling in marker is broken. link/unlink of hardlinks
      present in same directory can break marker accounting. Hence, if src
      and dst are in same directory in case of rename, dht - if it breaks
      rename into link/unlink operations - should instruct marker to not to
      do accounting.
    
    Change-Id: I9c9f7384569f75a2792f6450ee7a5279bf751ae7
    BUG: 1022995
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: http://review.gluster.org/6203
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 59 Niels de Vos 2014-04-17 07:50:02 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.