Bug 102303 - named doesn't load new secondary zones on 'rndc reload'
named doesn't load new secondary zones on 'rndc reload'
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-13 14:04 EDT by P Fudd
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-20 18:42:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description P Fudd 2003-08-13 14:04:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I've got a shell script that rewrites /etc/named.conf to include new secondary
zones.  It then does 'rndc reload' to make them take effect.  It used to work
with older versions of bind, but not now.

Version-Release number of selected component (if applicable):
bind-9.2.1-9

How reproducible:
Always

Steps to Reproduce:
1.  echo 'zone "foobar.com" {type slave; file "sec/foobar.com"; masters {
2.2.2.2; }; };' >> /etc/named.conf
2.  rndc reload
3.  grep foobar.com /var/log/messages
4.  nslookup foobar.com localhost
5.  ls /var/named/sec/foobar.com
    

Actual Results:  foobar.com is not copied from the master server unless named is
stopped and started again.  foobar.com is not mentioned in the log file, the
file doesn't appear, and queries for it fail.

Expected Results:  It should get copied and the server should serve it.

Additional info:

I do have the following lines in /etc/sysconfig/named:
ROOTDIR=/var/named
I copied the following stuff into /var/named:

/dev/null /dev/random /dev/urandom /etc/named.conf /etc/rndc.conf /etc/rndc.key
/var/run

The /etc files are symlinked back to the real /etc directory.
Everything runs normally, except that rndc reload doesn't load new zones anymore.
Comment 1 Daniel Walsh 2003-08-18 17:00:48 EDT
Could you check to see if 
kill -HUP `cat /var/run/named/named.pid`
works correctly?

Comment 2 P Fudd 2003-08-20 18:30:34 EDT
I'm waiting for it to hang again.
Comment 3 P Fudd 2003-08-20 18:35:02 EDT
Ooops, sorry, wrong bug; disregard that last comment.
Comment 4 P Fudd 2003-08-20 18:41:12 EDT
I think I found the problem; /var/named/etc was only readable by root.

In addition, because /var/named/var/run is owned by named, named.pid is in this
directory, not /var/named/var/run/named, so that kill command gave a file not
found error.

Aren't chroot setups *fun*...

Note You need to log in before you can comment on or make changes to this bug.