Bug 1023038 - Remove definition of community maven repositories from dtgov workflows
Remove definition of community maven repositories from dtgov workflows
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER7
: 6.0.0
Assigned To: Kurt T Stam
Stefan Bunciak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 09:36 EDT by Stefan Bunciak
Modified: 2014-02-06 10:32 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Bunciak 2013-10-24 09:36:58 EDT
Description of problem:

pom.xml of default dtgov-workflows located in fsw-6.0.0-Beta/jboss-eap-6.1/data dir contains definition of definition of community maven repositories. My guess is that they have no use at all, since the dependencies are from product repositories.

Version-Release number of selected component (if applicable):
* 6.0.0.ER6 (Beta)
Comment 1 Kurt T Stam 2013-10-31 13:11:02 EDT
Hi Stefan,

This pom will require the download of the drools plugin and the srampWagon. He will need to have the product repository configured in his settings.xml, or we should replace the project repo setting with the product repo setting at productization time. I'll talk to Nick to see which way we should proceed om this.
Comment 2 Kurt T Stam 2013-11-07 12:30:30 EST
Everyone agrees the repo settings need to be available in the .m2/settings.xml, so I'm deleting the repo info from this pom.
Comment 3 Stefan Bunciak 2013-12-12 07:39:01 EST
Verified in FSW 6.0.0.ER7

Note You need to log in before you can comment on or make changes to this bug.