Bug 1023068 - Synaptics mouse stuck under heavy load
Synaptics mouse stuck under heavy load
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: 0ad (Show other bugs)
18
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 10:35 EDT by Peter H. Jones
Modified: 2014-02-05 17:30 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 17:30:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (58.56 KB, text/plain)
2013-10-24 10:35 EDT, Peter H. Jones
no flags Details
Xorg.0.log after freeing the mouse with CTRL-ALT-Fn sequence (79.86 KB, text/plain)
2013-10-24 10:37 EDT, Peter H. Jones
no flags Details
Xorg.0.log before mouse got stuck (39.03 KB, text/plain)
2013-10-25 03:31 EDT, Peter H. Jones
no flags Details
Xorg.0.log after recovering from stuck mouse (53.07 KB, text/plain)
2013-10-25 03:44 EDT, Peter H. Jones
no flags Details

  None (edit)
Description Peter H. Jones 2013-10-24 10:35:28 EDT
Created attachment 815816 [details]
dmesg output

Description of problem:
Mouse moves jerkily, then stops altogether under heavy load.

Version-Release number of selected component (if applicable):
xorg-x11-drv-synaptics-1.6.4-2.fc18.x86_64

How reproducible:
Usually can reproduce

Steps to Reproduce:
1. Run heavy usage command (see below)

Actual results:
Mouse response becomes jerky, then stops altogether, even if
I terminate the heavy usage command.

I freed the mouse with CTRL-ALT-F2, CTRL-ALT-F1.

Expected results:
Mouse should slow down, but not stall completely. Behaviour
should become normal when heavy load is terminated.

Additional info:

The heavy usage command is approximately:
"ls -do $(du -a |sort -n | tail -${1:-3000} | sed -n 's/.*	..//p' | grep -xvFf /run/media/$LOGNAME/2tp001data/wgwork/fullnames) | sort -nk4,4
"

The directory contains approximately 630,000 files in a USB ext4 partition.

I say "approximately because this command is given inside fc/vim,
and I have downloading to the same disk going on at the same time.

When the problem occurs, I am using about 600MB of memory out of 740MB
available, and about 400 MB of swap. The disk usage light is flickering
constantly.

Will attach dmesg output and Xorg.log.
Comment 1 Peter H. Jones 2013-10-24 10:37:19 EDT
Created attachment 815819 [details]
Xorg.0.log after freeing the mouse with CTRL-ALT-Fn sequence
Comment 2 Peter H. Jones 2013-10-25 03:31:30 EDT
Created attachment 816030 [details]
Xorg.0.log before mouse got stuck

Tried to make the bug happen. With only termnal windows active, mouse was sometimes sluggish, but didn't get stuck.
Comment 3 Peter H. Jones 2013-10-25 03:44:18 EDT
Created attachment 816032 [details]
Xorg.0.log after recovering from stuck mouse

Tried running Midori. Suddenly, Midori crashed with a signal 11. The ABRT window showed the crash was due to Adobe Flash Player. Mouse got stuck while I was using the ABRT window. Recovered with CTRL-ALT-2, CTRL-ALT-1.
Comment 4 Fedora End Of Life 2013-12-21 09:42:39 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 5 Fedora End Of Life 2014-02-05 17:30:26 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.