Bug 1023155 - infinite loop in rogue inventory
infinite loop in rogue inventory
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: rogue (Show other bugs)
22
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Alexandre Moine
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 13:53 EDT by Tom Holroyd
Modified: 2016-07-19 14:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 14:59:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Possibly unrelated, but here is a rouge.save file that causes rogue to segfault instantly. (51.12 KB, application/octet-stream)
2016-03-15 14:52 EDT, Tom Holroyd
no flags Details

  None (edit)
Description Tom Holroyd 2013-10-24 13:53:25 EDT
Description of problem:

I was playing rogue (I'm on vacation!) and on level 11 I found a Nymph. The proper way to fight a Nymph is to drop everything you are carrying and fight her barehanded and naked. Otherwise when she hits she'll steal an item.

I defeated the Nymph, and she dropped a Leather Armor. I picked it up and it showed up in my inventory as b) leather armor, and of course it was the only thing I was carrying, having dropped everything else. So I don't know why it was b). Then I tried to drop it, but it claimed there was something already there, or something (I don't remember exactly). Then I did an inventory and saw

b) leather armor
b) leather armor
b) leather armor
...
--press space to continue--

and no matter how many spaces I pressed, it just kept saying b) leather armor.
I couldn't do anything and had to ^C to get out.

Version-Release number of selected component (if applicable):

rogue.i686                         5.4.5-12.fc19

I used to play rogue all the time in the 80's and this version works pretty well. I think there might be an issue with the high-score list too but that's not a big deal. This issue is "high" 'cause when it happens it kills your game. I was having an excellent game otherwise, and got slightly annoyed by this. :-)
Comment 1 Tom Holroyd 2013-10-24 13:59:07 EDT
Oh, I had saved the game earlier, so I was playing from a restored game, if that makes a difference. It seems to me it's just some bug related to having nothing in your pack. I've dropped everything and picked everything up before and that seems to work fine, but this item (leather armor) was dropped by a Nymph after I defeated it so maybe that has something to do with it. I dunno. I'm on vacation so maybe I'll look at the code. I'm also having problems with my Samba server and I want to look at that code, but like I said, I'm on vacation. After two weeks of being furloughed by the government, they start up and I get two days to fix everything in the lab and then I'm out (hey, my vacation was planned for months!) You don't care about any of this, I know. You fix this and I'll fix the Samba bug, deal?
Comment 2 Petr Šabata 2013-10-30 04:27:13 EDT
I understand your frustration but it will probably take a while until I find some time to reproduce it :)  I'm open to patches, of course.

I know the saving/restoring is a bit broken; I'd look there.

Also, in case you have saved before the nymph, could you attach the save file?
Comment 3 Tom Holroyd 2013-10-30 15:16:38 EDT
Sorry, when you start with -r it reads and then deletes the save file, and I hadn't made a copy. If I had had it and it worked I probably wouldn't have reported this. :-)
Comment 4 Fedora End Of Life 2015-01-09 17:20:54 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 5 Petr Šabata 2015-01-12 09:17:54 EST
I still haven't really looked at this yet :|
Comment 6 Jaroslav Reznik 2015-03-03 11:56:31 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 7 Fedora Admin XMLRPC Client 2016-03-12 11:07:27 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Fedora Admin XMLRPC Client 2016-03-12 11:44:00 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Tom Holroyd 2016-03-15 14:52 EDT
Created attachment 1136700 [details]
Possibly unrelated, but here is a rouge.save file that causes rogue to segfault instantly.

I was trying to reproduce the earlier bug, which may have something to do with save files. You'll need to adjust the screen to 90x24 chars, it complains if you don't. In any case, this is also a bug---it should not segfault.
Comment 10 Fedora End Of Life 2016-07-19 14:59:05 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.