Bug 1023187 - Encountered an atom feed entry with an unknown event
Encountered an atom feed entry with an unknown event
Status: CLOSED CURRENTRELEASE
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bryan Kearney
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 16:17 EDT by John Sefler
Modified: 2016-07-22 10:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-22 10:39:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
atomFeedBug.xml (475.64 KB, text/xml)
2013-10-24 16:18 EDT, John Sefler
no flags Details

  None (edit)
Description John Sefler 2013-10-24 16:17:17 EDT
Description of problem:
I have an automated EventsTests that includes an assertion loop that looks at the xml returned from an atom feed.  If one of the entries contains a description with an "Unknown event" substring, then the test throws a failure.  I'm not exactly sure what circustances are causing the event, nevertheless here are some sketchy details...

Encountered an atom feed entry with an unknown event: Event Feed entries[5].getTitle()=RULES MODIFIED   .getDescription()=Unknown event for user admin and target 4.4

curl -k -u admin:admin https://jsefler-f14-candlepin.usersys.redhat.com:8443/candlepin/atom > atomFeedBug.xml

Attached is the atomFeedBug.xml that contains the offending "Unknown event" description.


Version-Release number of selected component (if applicable):
[root@jsefler-f14-candlepin candlepin]# git show-ref | grep master
b74b19b072fcd336b717864e38e577b3e6792863 refs/heads/master
Comment 1 John Sefler 2013-10-24 16:18:19 EDT
Created attachment 815914 [details]
atomFeedBug.xml
Comment 2 Devan Goodwin 2013-10-24 16:21:31 EDT
For whomever picks this up it looks like a missing entry in the map in EventAdapterImpl, used in addMessageText.
Comment 3 Bryan Kearney 2013-10-25 13:24:06 EDT
https://github.com/candlepin/candlepin/pull/416
Comment 4 Bryan Kearney 2013-11-01 08:07:11 EDT
commit cd4921e729a04b60f10296277105f6d045221953
Author: Bryan Kearney <bkearney@redhat.com>
Date:   Fri Oct 25 13:22:18 2013 -0400

    1023187: Events for Rules addition and delete were missing event string.
    
    This resulted in messages in the atom feed such as
    
    <messageText>Unknown event for user admin and target 4.4</messageText>
    
    New strings were addded, and the correct text is shown.
Comment 5 Mike McCune 2016-03-28 18:20:08 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Barnaby Court 2016-07-22 10:39:35 EDT
Moving to closed per the updated candlepin process for bugs that have been merged or have been taken care of.

Note You need to log in before you can comment on or make changes to this bug.